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Home > Success Center > Network Performance Monitor (NPM) > Add nodes with the same hostname using Network Discovery

Add nodes with the same hostname using Network Discovery

Created by Zoltán Jalsovszky, last modified by MindTouch on Jun 23, 2016

Views: 136 Votes: 0 Revisions: 8

Overview

This article provides brief information and steps to resolve the issue when machines with the same hostname but different IP addresses are not added in the Network Discovery.

Environment

NPM version 11.5 and later

Cause

The issue is caused when Network Discovery detects the nodes with the same hostname as duplicates. 

Steps

Warning: SolarWinds strongly recommends that you create a full backup of your database. The following procedure may result in system performance issues or may create an error state.

 

1. Stop all Orion services from the Orion Service Manager

 

Warning: SolarWinds strongly recommends that you only edit the SolarWinds.Orion.Discovery.Job.dll.config file as instructed. Any additional modifications may result in system performance issues or may create an error state.

 

2. Open SolarWinds.Orion.Discovery.Job.dll.config in a text editor. The default location is C:\Program Files (x86)\SolarWinds\Orion\SolarWinds.Orion.Discovery.Job.dll.config.

3. Locate the following lines:

<add key="DisableSysNameDuplicateDetector" value="false" />
<add key="DisableDNSDuplicateDetector" value="false" />

 

4. Replace with the following lines:

<add key="DisableSysNameDuplicateDetector" value="true" />
<add key="DisableDNSDuplicateDetector" value="true" />

5. Save the file. 

6. Restart all Orion services. 

7. Re-run Network Discovery. 

 

 

 

Last modified
21:40, 22 Jun 2016

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