Submit a ticketCall us

Systems Monitoring for Dummies
Our new eBook will teach you the fundamentals and help you create monitors and alerts that are effective, meaningful, and actionable. Monitoring is more than a checkbox on your to-do list. This free eBook will give you practical advice to help you succeed in all aspects of monitoring – discovery, alerting, remediation, and troubleshooting. Don’t miss out on this indispensable resource for newbies, experienced IT pros, and everyone in between. Register Now.

Home > Success Center > Network Performance Monitor (NPM) > A Universal Device Poller test passes, but polling fails when assigned to a node

A Universal Device Poller test passes, but polling fails when assigned to a node

Updated September 13th, 2017

Overview

Tests of Universal Device Poller pass successfully in the UDP tool. However, when assigned to a node, A Universal Device Poller tests fine in the Universal Device Poller tool but when assigned to the node it doesn't return any data or initiate polling.

 

Environment

  • All versions of NPM

 

Cause 

This issue is caused by:

  • An improper configuration of the fetching type GET/GET NEXT/GET TABLE
  • There is a problem with the Collector and JobEngine SDFs.

 

 

Resolution

To ensure configuration, view the following document that details the procedure to create a Universal Device Poller:

 

If the above is verified then the SDFs with the solution in the following:

 

 

Last modified

Tags

Classifications

Public