Submit a ticketCall us

Don’t fall victim to a ransomware attack
Backups are helpful, but sometimes that’s not enough to protect your business against ransomware. At our live webcast we will discuss how to protect against ransomware attacks with SolarWinds® Patch Manager and how to leverage log data to detect ransomware. Register now for our live webcast.

Home > Success Center > Network Configuration Manager (NCM) > The SolarWinds NCM software was unable to get data from SQL server

The SolarWinds NCM software was unable to get data from SQL server

Created by Brian O'Donovan, last modified by MindTouch on Jun 23, 2016

Views: 27 Votes: 0 Revisions: 7

Overview

The following error message is received when launching the NCM tool:

The SolarWinds NCM software was unable to get data from SQL server:
[
Cannot open database "pm" requested by the login. The login failed.
Login Failed for user "sa".
]

Environment

NCM 7.2.2 and earlier

Cause 

This issue is caused by running the Orion Configuration Wizard and creating a new database instead of connecting to the existing DB. This broke the NPM / NCM integration.

Resolution

  1. Run NCM Configuration Wizard.
    1. Go to Start > SolarWinds Orion > Network Configuration Manager > SolarWinds NCM Configuration Wizard.
    2. Verify the settings.
    3. Complete the wizard.
  2. Run Orion Configuration Wizard.
Last modified
21:31, 22 Jun 2016

Tags

Classifications

Public