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Home > Success Center > Network Configuration Manager (NCM) > SSHv2 Failing to download configs on Dell Force10 devices

SSHv2 Failing to download configs on Dell Force10 devices

Created by Allain M Umalin, last modified by MindTouch on Jun 23, 2016

Views: 680 Votes: 0 Revisions: 4

Overview

The following behavior are present on this issue:

  • Unable to download configs from Dell Force10 devices
  • Test under NCM after editing node is working fine
  • Able to  download configs via SSHv1
  • SSHv2 works from putty on the same server and from every other locations around the network
  • Session Trace events:

[4/12/2016 12:50:20 PM] Got HostFingerPrint:

###fingerprint###
[4/12/2016 12:50:20 PM] SWTelnet9 Crypto Information Begin 
[4/12/2016 12:50:20 PM] Protocol = SSH2
[4/12/2016 12:50:20 PM] RemoteName = SSH-1.99-SSH_v2.0@force10networks.com
[4/12/2016 12:50:20 PM] SCcipher = 3des-cbc
[4/12/2016 12:50:20 PM] CSCipher = 3des-cbc
[4/12/2016 12:50:20 PM] Keys = ssh-rsa
[4/12/2016 12:50:20 PM] SWTelnet9 Crypto Information End
[4/12/2016 12:50:21 PM] Banner received
[4/12/2016 12:50:21 PM] Got Login Challenge: 
[4/12/2016 12:50:21 PM] TimerTick: mstrData=<> State=1 - Connecting to server
[4/12/2016 12:50:21 PM] Pending Disconnect = False
[4/12/2016 12:50:21 PM] TimerState not Idle, Leaving.
[4/12/2016 12:50:21 PM] Solarwinds.Net SWTelnet9 Version 9.0.27
[4/12/2016 12:50:21 PM] Connected! Invalid username or password reported by server, or bad private key.
[4/12/2016 12:50:21 PM] -->StateChange: Disconnected from server<--

Environment

All NCM Versions

Cause 

A third-party component WodSSH is not able to establish connection to device using SSH2.

Resolution

  1. Establish a remote access to the device via external IP address or VPN.
  2. Open a support ticket to WodSSH vendor to investigate the issue. 
  3. A workaround is to download configs via SSHv1.
Last modified
21:30, 22 Jun 2016

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