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Home > Success Center > Network Configuration Manager (NCM) > Real-time change notification emails not sent for some Cisco devices

Real-time change notification emails not sent for some Cisco devices

Created by Malik Haider, last modified by MindTouch on Jun 23, 2016

Views: 110 Votes: 2 Revisions: 16

Overview

This article addresses the issue when Real-Time Change Notification for some Cisco devices does not work and the following have been confirmed:

  • Email SMTP is working.
  • Trap rules are working.
  • Device's config has been downloaded .
  • Email settings under Real-Time Change Detection.

Environment

NCM 7.3 through 7.4.1

Cause 

This occurs when the trap message is too long and does not fit into the Orion database column allocation.

Resolution

  1. Open Database Manager
  2. Select the Orion Database.
  3. Right-click the database and select New Query.
  4. Paste the following query:
    ALTER TABLE NCM_RTNAudit
    ALTER COLUMN Message nvarchar (max) NOT NULL

    Note: To copy content without line numbers, hover over the text and click the view source button (View Source). This opens a new window where you can select and copy text without any formatting or line numbering.

     

  5. Click Execute query.

 

Note:

This issue is fixed in NCM 7.5

Last modified
21:29, 22 Jun 2016

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