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Random Config Download Error: NcmBussinessLayerPlugin.log

Created by Jeremy Ruth, last modified by Norbert Skurzewski on Aug 18, 2017

Views: 1,707 Votes: 1 Revisions: 5

Overview

The following error appears in the Web Console while manually downloading configurations:

Error Processing results. See NcmBusinessLayerPlugin log for details

 

Then further in NcmBusinessLayerPlugin.log:

ERROR SolarWinds.Cirrus.BusinessLayer.DAL.ComparisonCacheDAL - Unable to cache diff results due to exception: System.OutOfMemoryException: Exception of type 'System.OutOfMemoryException' was thrown

Environment

NCM version 7.4 

NCM version 7.6

 

Cause 

The error is occurs when there is not enough memory for the Business Layer to process the  request. 

Resolution

FOR NCM 7.4:

1. Open the Orion Install directory. The default location is C:\Program Files (x86)\SolarWinds\Orion.

2. Open SolarWinds.BusinessLayerHost.exe.config.

3.  Find the following line:

<add key="ForcePluginsInSeparateProcess" value="False"/>

4. Replace it with: 

<add key="ForcePluginsInSeparateProcess" value="True"/>

5. Save the file. 

6. Restart Orion Services for the changes to take effect.

 

FOR NCM 7.6:

1. Go to your Orion Web Console
2. Go to this page :
http:YOUR IP OR HOSTNAME/orion/admin/AdvancedConfiguration/Global.aspx
3. Search for "ForcePluginsInSeparateProcess"
4. Tick the box
5. Click SAVE
6. Restart Orion Module Engine

 

This allows to run the different Business Layer modules in their own separate processes, thus increasing the total memory available to the module service.

 

 

 

 

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