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Home > Success Center > Network Configuration Manager (NCM) > RUNQUERY FAILED, CHECK FAULT INFORMATION error on NCM Configuration Management page

RUNQUERY FAILED, CHECK FAULT INFORMATION error on NCM Configuration Management page

Created by Adrian Cook, last modified by Karen Valdellon_ret on Apr 19, 2017

Views: 567 Votes: 1 Revisions: 5

Overview

The error RUNQUERY FAILED, CHECK FAULT INFORMATION is displayed and the configurations under the device are not shown. Check the Information Service v3 log for the following (or similar) error:

2016-05-03 07:12:24,181 [52] ERROR SolarWinds.InformationService.Core.InformationService - System.RuntimeMethodHandle._InvokeMethodFast()      Exception caught in method RunQuery
SolarWinds.Data.Query.ParserException: Alias [ID] already defined

Environment

NCM 7.1 and later

Cause 

The error is thrown because there is a custom property that has the same name as a field in the query that NCM is running to display the configurations. In this case, the custom property was named ID.

Resolution

  1. Go to Settings > Manage Custom Properties and check if the property causing the issue exists.
  2. If so, export the values to XLS, and then create a new custom property that is not named the same as a field in NCM.
  3. Import the values to the new property and delete the one that is causing the issue.
  4. Update any reports or alerts using the custom property to point to the new custom property you created.

 

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