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Home > Success Center > Network Configuration Manager (NCM) > NCM is unable to connect to Cisco ASA

NCM is unable to connect to Cisco ASA

Updated January 30, 2017

Overview

In general NCM should have no problems connecting, logging in and working with a Cisco ASA provided that NCM is configured with the correct login credentials, correct protocols chosen and Device Template selected. There are times when an ASA may not append the Hostname to the Prompt, leaving only the # at the enable mode. This may cause NCM not to fully engage

Environment

  • All NCM versions
  • Cisco ASA

Cause 

The Enable Prompt is a single #.

Resolution

On Cisco ASA, use the prompt hostname command so the device will send the hostname with the prompt, or

make a copy of the Cisco Adaptive Security Appliance Template and add the following commands

  1. <Command Name="MenuBased" Value="False"/>
  2. <Command Name="VirtualPrompt" Value=">"/>
  3. <Command Name="VirtualEnablePrompt" Value="#"/>
  4. Set the New Template to have a unique name.
  5. Set the New Template not to be used for Auto determine.
  6. After saving the template, edit the ASA(s) displaying this behavior and manually set the new device template to be used in the communication section.

 

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