Submit a ticketCall us

Announcing NCM 7.7
With NCM 7.7, you can examine the rules that make up an access control list for a Cisco ASA device. Then you can apply filters to display only rules that meet the specified criteria, order the rules by line number or by the hit count, and much more.
See new features and improvements.

Home > Success Center > Network Configuration Manager (NCM) > NCM Jobs Fail with ERROR: unable to retrieve EngineID

NCM Jobs Fail with ERROR: unable to retrieve EngineID

Updated December 9th, 2016

Overview

If you receive an error when running a job ERROR: unable to retrieve EngineID 

Environment

  • NCM 7.x.x

Cause 

This could be caused by a recent migration. The jobs that are created are assigned to the work engineID.

Resolution

  1. Stop Orions Services
  2. Open database manager  Open database manager Start all programs > Solarwinds Orion > Advanced Feature > Database Manager > Click "Add Default Server" and Check the Engine ID assigned to the jobs in the NCM_JobEngineNCMJobs table.
  3. Compare that EngineID to the one on the AllEngines or Engines table in the database. 
  4. If they do not match, click enable table editing on  NCM_JobEngineNCMJobs table
  5. Enter the correct EngineID in the EngineID column for the affected jobs. 

 

 

Last modified
16:18, 24 Feb 2017

Tags

Classifications

Public