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Home > Success Center > Network Configuration Manager (NCM) > NCM - Knowledgebase Articles > The NPM Summary home page intermittently loses connection

The NPM Summary home page intermittently loses connection

Created by John Salvani, last modified by MindTouch on Jun 23, 2016

Views: 1,351 Votes: 0 Revisions: 6

Overview

The NPM Summary home page intermittently loses connection. The following error occurs:

There was no endpoint listening at net.tcp://npmserver:17777/orion/core/businesslayer that could accept the message. This is often caused by an incorrect address or SOAP action. See InnerException, if present, for more details

 

The Busineslayerhost.log file displays the message:

2015-02-17 08:32:21,084 [Scheduler] ERROR SolarWinds.Common.Utility.ScheduledTask - CheckPlugins threw an exception.

System.InvalidOperationException: Instance C:\Program Files (x86)\SolarWinds\Orion\AgentManagement\SolarWinds.AgentManagement.ServiceCore.dll.config - ProcessID:12812 doesn't exists anymore
   at SolarWinds.BusinessLayerHost.PluginInstanceSeparateProcess.KeepAlive()
   at SolarWinds.BusinessLayerHost.PluginManager.CheckHealth()
   at SolarWinds.BusinessLayerHost.BusinessLayerHostService.CheckPlugins(Object state)
   at SolarWinds.Common.Utility.ScheduledTask.DoWork()
   at SolarWinds.Common.Utility.ScheduledTask.Run()
2015-02-17 08:32:21,087 [27] ERROR SolarWinds.BusinessLayerHost.BusinessLayerHostService - Unhandled exception caught by business layer host. System.InvalidOperationException: Instance C:\Program Files (x86)\SolarWinds\Orion\AgentManagement\SolarWinds.AgentManagement.ServiceCore.dll.config - ProcessID:12812 doesn't exists anymore
   at SolarWinds.BusinessLayerHost.BusinessLayerHostService.<>c__DisplayClass6.<CheckPlugins>b__5(Object n)
   at System.Threading.QueueUserWorkItemCallback.WaitCallback_Context(Object state)
   at System.Threading.ExecutionContext.RunInternal(ExecutionContext executionContext, ContextCallback callback, Object state, Boolean preserveSyncCtx)

Environment

NPM 10.6 and later

Cause 

There are errors in the Businesslayerhost.log file.

Resolution

Warning:

  • Consult your System Administrator before performing the following procedure.
  • SolarWinds strongly recommends that you only edit the SolarWinds.AgentManagement.Watchdog.dll.config file as instructed. Any additional modifications may result in system performance issues or may create an error state.
  • Save a copy of the original SolarWinds.AgentManagement.Watchdog.dll.config file to your local drive as a backup file, in case you need to roll back later.
     
  1. Go to C:\Program Files (x86)\SolarWinds\Orion\AgentManagement\  and save a copy of the SolarWinds.AgentManagement.Watchdog.dll.config file as a back up file, in case you need to rollback later.
  2. Open SolarWinds.AgentManagement.Watchdog.dll.config in a text editor
  3. Change pingFrequency="0.00:02:00" to pingFrequency="0.00:01:00".
  4. Change maxAllowedPingDelay="0.00:04:00" to maxAllowedPingDelay="0.00:10:00".
  5. Save the changes.
  6. Restart SolarWinds Orion Module Engine service.
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