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Home > Success Center > Network Configuration Manager (NCM) > NCM - Knowledgebase Articles > Scheduled job runs twice at the same time

Scheduled job runs twice at the same time

 Updated June 22nd, 2018

Overview

After upgrading to a single database model (NCM 7.3 and later), some of the jobs run twice at the same time while there is only a single schedule set for the job.

Environment

NCM 7.3, all supported versions

Cause

Duplicate records in the Job Engine v2 database and occurring in multi-polling engine environments only while migrating NCM jobs from NCM native database to the Orion database.

Resolution

Reset Job Engine v2 database following steps below:

  1. Log in to the Orion server where duplicate job is executing (Primary Polling Engine).
  2. Using Orion Service Manager, stop all services
  3. Go to C:\ProgramData\Solarwinds\JobEngine.v2\Data.
  4. Rename JobEngine35.sdf to JobEngine35.sdf.old or simply delete it.
  5. Make a copy of JobEngine35 - Blank.sdf and rename the copy to JobEngine35.sdf.
  6. Right-click JobEngine35.sdf, select Properties and make sure that the file is NOT blocked or set to read-only.
  7. Go to C:\WINDOWS\Temp\SolarWinds.
  8. Delete the JobEngine.v2 folder.
  9. Using Orion Service Manager, start all services.

 

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