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Home > Success Center > Network Configuration Manager (NCM) > NCM - Knowledgebase Articles > Random Config Download Error: NcmBussinessLayerPlugin.log

Random Config Download Error: NcmBussinessLayerPlugin.log

Overview

The following error appears in the Web Console while manually downloading configurations:

Error Processing results. See NcmBusinessLayerPlugin log for details

 

Then further in NcmBusinessLayerPlugin.log:

ERROR SolarWinds.Cirrus.BusinessLayer.DAL.ComparisonCacheDAL - Unable to cache diff results due to exception: System.OutOfMemoryException: Exception of type 'System.OutOfMemoryException' was thrown

Environment

NCM version 7.6 and later

Cause 

The error is occurs when there is not enough memory for the Business Layer to process the  request. 

Resolution

1. Go to your Orion Web Console
2. Go to this page :
http:YOUR IP OR HOSTNAME/orion/admin/AdvancedConfiguration/Global.aspx
3. Search for "ForcePluginsInSeparateProcess"
4. Tick the box
5. Click SAVE
6. Restart Orion Module Engine

 

This allows to run the different Business Layer modules in their own separate processes, thus increasing the total memory available to the module service.

 

 

 

 

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