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NCM System Check Error: Source files for one or more products are missing

Updated February 28, 2018

Overview

This articles details and provides steps to resolve the following error received during a system check when upgrading from NCM 7.6 to NCM 7.7:

Missing Installation sources files

 

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Environment

  • NCM 7.6

 

Cause 

  • The source files for one or more products are missing.
  • A bad installation and/or corrupted files.

 

Resolution

Download the Microsoft Program Install and Uninstall troubleshooter tool from https://support.microsoft.com/en-us/help/17588 and apply (Uninstall) it to the following programs:

Disclaimer: Please note, any content posted herein is provided as a suggestion or recommendation to you for your internal use. This is not part of the SolarWinds software or documentation that you purchased from SolarWinds, and the information set forth herein may come from third parties. Your organization should internally review and assess to what extent, if any, such custom scripts or recommendations will be incorporated into your environment.  You elect to use third party content at your own risk, and you will be solely responsible for the incorporation of the same, if any.

  1. SolarWinds Orion Core
  2. SolarWinds Active Diagnostics
  3. SolarWinds Job Engine
  4. SolarWinds Job Engine V2
  5. SolarWinds Collector
  6. Information Service
  7. SolarWinds Network Atlas
  8. SolarWinds MIBs
  9. SolarWinds Administration Service
  10. RabbitMQ Server
  11. SolarWinds High Availability
  12. SolarWinds Orion High Availability
  13. SolarWinds Improvement Program
  14. Network Configuration Manager
  15. Run the NPM 7.7 install

 

For full list for your environment, check what needs to be uninstalled using Orion Installer Logs.

For example:

  • C:\ProgramData\Solarwinds\LogFiles\Orion\Installer\2018-06-18_14-17-52\ AdministrationService.Client.log
  • "Name": "Missing installation source files",
  • "Description": "The source files for one or more products are missing.",
  • "Resolution": "Download the Microsoft Program Install and Uninstall troubleshooter tool from https://support.microsoft.com/en-us/help/17588  and apply it to the following programs:
    SolarWinds Orion Core, IP Address Manager, Network Configuration Manager
  • Network Performance Monitor, Server & Application Monitor, VoIP & Network Quality Manager, User Device Tracker,
  • SolarWinds Active Diagnostics, SolarWinds Job Engine, SolarWinds Collector, Information Service, SolarWinds Network Atlas, SolarWinds MIBs, SolarWinds Administration Service, RabbitMQ Server,
  • SolarWinds High Availability, SolarWinds Orion High Availability, SolarWinds Improvement Program, WinPCap Driver, WinPCap Driver, SolarWinds NetPath, Recommendations, Virtual Infrastructure Monitor,
  • SolarWinds Quality of Experience, TFTP Server", DPA Integration Components,

 

During an install or update of SolarWinds products, SolarWinds recommends that you log in to your Orion systems with the local Administrator account (do not use a Domain Admin account) to avoid GPOs and any other potential permission issues. You can also right-click the application and "Unblock", then right-click and Install as an Administrator.

 

 

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