Submit a ticketCall us

AnnouncementsFace your biggest database issues head-on

Our new eCourse helps you navigate SQL Server performance blocks by teaching you how to recognize and deal with the three DBA Disruptors: Performance Hog, Blame Shifter, and Query Blocker. Register today to learn how to defend your environment and fend off menacing disruptions.

Register for your free eCourse.

Home > Success Center > Network Configuration Manager (NCM) > NCM - Knowledgebase Articles > Error processing results. See NcmBusinessLayerPlugin.log for details (NCMTransfer IP:xx.xx.xx.xxProcessResultsAsync Error System.IO.IOException: The file exists)

Error processing results. See NcmBusinessLayerPlugin.log for details (NCMTransfer IP:xx.xx.xx.xxProcessResultsAsync Error System.IO.IOException: The file exists)

Created by Jeremy Ruth, last modified by Caroline Juszczak on Sep 05, 2017

Views: 1,841 Votes: 1 Revisions: 5

Overview

This article describes the issue when the config continues to download and you review C:\ProgramData\Solarwinds\Logs\Orion\NCM\NCMBusinessLayerPlugin.log, the following error appears:

ERROR SolarWinds.Cirrus.BusinessLayer.TransferEngine.TransferManager - NCMTransfer IP:xx.xx.xx.xxProcessResultsAsync Error System.IO.IOException: The file exists.

 

Environment

All versions of NCM

 

Cause 

This error occurs when the temp folder is not clearing. There might be a GPO or an Antivirus that is not allowing files in the temp folder to be deleted. This is impacting the cache results error we see in the logs. 

Resolution

 

  1. Open the file explorer.
  2. Navigate to C:\Windows\Temp and remove unnecessary files. Some of them may be locked by other processes. Ignore these files.
  3. Navigate to C:\Users\.
  4. For each user folder, navigate to AppData\Local\Temp and remove any unnecessary files.
  5. Test with a config download.

 

Last modified

Tags

Classifications

Public