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Home > Success Center > Network Configuration Manager (NCM) > NCM - Knowledgebase Articles > Error: Array dimensions exceeded supported range

Error: Array dimensions exceeded supported range

Last Updated: March 7, 2018

Overview

When you attempt to clear a job's history log, you might receive the following error:

Array dimensions exceeded supported range

 

For example, when you click the Job Log link, you receive a message that the log file is too large to display. 

 

 

When you click the Clear Log button, the error message is displayed:

Environment

NCM, all supported versions

Cause

This issue is caused by architectural (internal) limitation of data structures used in software while data structures on the database side allow for a much larger size.

Resolution

  1. Back up the database before you perform any further steps which involve direct changes to the table content. For more information, see the SQL Server documentation. 
  2. Open either the Orion Database Manager available on the Orion server or SQL Server Management Studio from Microsoft.
  3. Run the following query against the Orion database to delete history for all NCM Jobs:
    UPDATE [NCM_NCMJobs]
    SET [JobLog] = NULL
    
  4. To verify, open the Jobs page and see if the logs are removed.

 

 

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