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Home > Success Center > Network Configuration Manager (NCM) > NCM - Knowledgebase Articles > Download fails when using SSH2

Download fails when using SSH2

Updated July 19, 2017

Overview

A download fails when using SSH2 to connect to devices.

Environment

NCM 7.6

Cause 

The SSH protocol is set to a short interval. The following shows a session trace that may show a similar output:

[17.07.2017 15:32:39] Connection Timeout in seconds: 10
[17.07.2017 15:32:39]
-->StateChange: Connecting to server<--

[17.07.2017 15:32:41] TimerTick: mstrData=<> State=1 - Connecting to server
[17.07.2017 15:32:41] Pending Disconnect = False
[17.07.2017 15:32:41] TimerState not Idle, Leaving.
[17.07.2017 15:32:43] TimerTick: mstrData=<> State=1 - Connecting to server
[17.07.2017 15:32:43] Pending Disconnect = False
[17.07.2017 15:32:43] TimerState not Idle, Leaving.
[17.07.2017 15:32:45] TimerTick: mstrData=<> State=1 - Connecting to server
[17.07.2017 15:32:45] Pending Disconnect = False
[17.07.2017 15:32:45] TimerState not Idle, Leaving.
[17.07.2017 15:32:47] TimerTick: mstrData=<> State=1 - Connecting to server
[17.07.2017 15:32:47] Pending Disconnect = False
[17.07.2017 15:32:47] TimerState not Idle, Leaving.
[17.07.2017 15:32:49] TimerTick: mstrData=<> State=1 - Connecting to server
[17.07.2017 15:32:49] Pending Disconnect = False
[17.07.2017 15:32:49] TimerState not Idle, Leaving.
[17.07.2017 15:32:49] Solarwinds.Net SWTelnet9 Version 9.0.27
[17.07.2017 15:32:49] Connected! The current connection has timeout.
[17.07.2017 15:32:49]
-->StateChange: Disconnected from server<--

 

Resolution

  1. Go to NCM Settings > Protocol settings.
  2. Set the Telnet/SSH Connection timeout to a default value as displayed in the Protocol settings page (45 seconds).

 

 

 

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