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Home > Success Center > Network Configuration Manager (NCM) > Jobs are not visible and changes in NCM / User Roles cannot be made

Jobs are not visible and changes in NCM / User Roles cannot be made

Updated March 11th, 2016

Overview

NCM roles allow or restrict the user's ability to perform certain actions in NCM. For example, users with the Administrator role can perform the following actions:

  • View other users' jobs (see all jobs)
  • Execute scripts without approval
  • Create jobs
  • Run scripts
  • Modify node properties
  • Add or remove nodes from Node Selection

If a user should be able to perform a action (such as see all jobs), but they cannot, verify that the correct role is assigned. (See the Resolution.)

Available roles and level of access

  1. Administrator - Unlimited access to NCM functionality.
  2. Engineer - Admin but cannot view config transfer status from all users.
  3. WebUploader - Unlimited read/write access unless Approval system is enabled. No access to settings.
  4. WebDownloader - Read only access with ability to download configs. No access to settings.
  5. WebViewer - Read only access. No access is granted to settings.
  6. None - No access to NCM functionality.

Environment

NCM 7.0 or later

Cause

The issue is caused by an NCM role being incorrectly assigned to the user account.

Resolution

  1. Log in to the Web Console as an Orion Administrator.
  2. Click Settings > All Settings.
  3. Under User Accounts, click Manage Accounts.
  4. Select the user account. 
  5. Click Edit.
  6. Scroll down and expand the Network Configuration Manager Settings.
  7. Assign/Select the relevant role such as Administrator Role (see the role descriptions in the Overview).
  8. Click Submit.
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