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Home > Success Center > Network Configuration Manager (NCM) > Fortigate connection timeout for test/login

Fortigate connection timeout for test/login

Created by Milton Harris, last modified by Melanie Boyd on May 01, 2017

Views: 387 Votes: 3 Revisions: 6

Overview

When trying to use or change the template for FortiGate devices, you experience a timeout when you click TEST. But when you try to connect using SSH clientthe connection goes through fine without any additional user intervention.

Environment

NCM 7.4

Cause 

FortiGate is expecting a Virtual Prompt to get past $.

Resolution

  1. In the NCM Web Console, go to Settings > NCM Settings > Device Templates.
  2. Edit and make a copy of the Fortigate template.
    Note: you have to make a copy because if you try to edit the original, the website will throw an exception and tell you to make a copy first. You cannot directly edit default templates.
  3. Edit the Copy of Fortigate (for example, Fortigate2).
  4. Paste into the XML the following line: 
    <Command Name="VirtualPrompt" Value="$"/>​​​
  5. Save and exit.

Note: Make sure that VirtualPrompt is one word with capital V, capital P and not Virtual Prompt.

Last modified
14:39, 1 May 2017

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