Submit a ticketCall us

Looking to compare latest NPM features with previous versions of NPM?
The NPM new feature summary offers a comparison of new features and improvements offered with this release.

 

Home > Success Center > Network Configuration Manager (NCM) > Error processing results. See NcmBusinessLayerPlugin log for details (System.ArgumentOutOfRangeException)

Error processing results. See NcmBusinessLayerPlugin log for details (System.ArgumentOutOfRangeException)

Created by Milton Harris, last modified by MindTouch on Jun 23, 2016

Views: 63 Votes: 1 Revisions: 5

Overview

This article describes the issue when you are able to download the Running Configs but when try to click on download Startup Configs, an error message appears:

Error processing results. See NcmBusinessLayerPlugin log for details

 

When you look at NCM BusinessLayer plugin, it shows the following error: 

Unable to cache diff results due to exception: System.ArgumentOutOfRangeException: Index was out of range. Must be non-negative and less than the size of the collection
Parameter name: index

     

Environment

NCM version 7.x

Cause 

When config comparisons are set to Display Full Side by Side Comparison in NCM, devices that have large configs have larger amount of data which may result to receive this error. 

Resolution

Set the number of lines to display the before and after of the config to five or less.

This is not an action that inhibits NCM to display all the lines that are different on a config, but it shows the number of lines that are displayed before and after.

 

Last modified
21:06, 22 Jun 2016

Tags

Classifications

Public