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Home > Success Center > Network Configuration Manager (NCM) > Error: Array dimensions exceeded supported range

Error: Array dimensions exceeded supported range

Created by Mariusz Handke, last modified by MindTouch on Jun 23, 2016

Views: 393 Votes: 1 Revisions: 9

Overview

This article provides brief information and steps to resolve the following error when clearing job history logs:

Array dimensions exceeded supported range

 

Example screenshots from the Orion Web Console after clicking on the Job Log link :

 

 

 

And after an attempt to clear it (pressing Clear Log button):

Environment

NCM version 7.3 or later 

Cause 

This issue is caused by architectural (internal) limitation of data structures used in software while data structures at the database side allow for much larger size.

Resolution

  1. Create a backup database prior to executing any further steps which involve direct changes to the tables content. To do so check this article: Snapshot of Current Configuration (Database Back-Up)
  2. To complete steps below either use Orion Database Manager available on Orion server or SQL Server Management Studio from Microsoft.
  3. Use below query against Orion database to delete history for all NCM Jobs

UPDATE [NCM_NCMJobs]
SET [JobLog] = NULL

 

To verify, check on the Jobs page if logs are removed

 

 

Last modified
21:05, 22 Jun 2016

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