Submit a ticketCall us

Welcome to the NEW Success Center. Search all resources (documentation, videos, training, knowledge base articles) or browse resources by product. If you are unable to find what you are looking for, please contact us at customersuccess@solarwinds.com

 

 

 

 

Home > Success Center > Network Configuration Manager (NCM) > Discovery setup error - Invoke failed, check fault information.

Discovery setup error - Invoke failed, check fault information.

Created by Mariusz Handke, last modified by MindTouch on Jun 23, 2016

Views: 866 Votes: 1 Revisions: 4

Overview

This article provides solution to the following error which shows up while trying to run Network Sonar Discovery with NCM installed:

Time: 04/06/2016 09:25:54.7043
Server: Microsoft-IIS/8.5
Pipeline: Integrated
User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/49.0.2623.110 Safari/537.36
Error Instance: 8a0837d9d44543a9ab2b8097d44e6be7
User: DOMAIN\user
URL: http://172.16.0.6:8787/Orion/NCM/Discovery/Config/NCMCredentials.aspx
Referrer: http://172.16.0.6:8787/Orion/NCM/Discovery/Config/NCMCredentials.aspx
Message: Invoke failed, check fault information.
ErrorSite: mscorlib.RealProxy.HandleReturnMessage
ErrorType: System.ServiceModel.FaultException`1[[SolarWinds.InformationService.Contract2.InfoServiceFaultContract, SolarWinds.InformationService.Contract2, Version=2015.1.3.7028, Culture=neutral, PublicKeyToken=null]]

Environment

NCM 7.2 and later

Cause 

The proper NCM role not being assigned to the account.

Resolution

  1. Log in to the Orion Web Console.
  2. Navigate to Manage Accounts.
  3. Select the account under which the error occurs.
  4. Click Edit.
  5. Scroll down and expand Network Configuration Management options.
  6. Select the NCM Role (i.e. Administrator).
  7. Click Submit.
  8. Attempt setting up discovery again.

 

Last modified
21:05, 22 Jun 2016

Tags

Classifications

Public