Submit a ticketCall us

AnnouncementsWeb Help Desk Integrations eCourse

Looking to reduce response times? Sign up for our eCourse to learn how integrating Web Help Desk with Dameware Remote Support, Network Configuration Manager, Network Performance Monitor, and Server & Application Monitor can improve communication efficiencies.

Register here.

Home > Success Center > Network Configuration Manager (NCM) > Comparison criteria does not work for Cisco ASA

Comparison criteria does not work for Cisco ASA

Created by Malik Haider, last modified by Bill Corgey on Dec 06, 2016

Views: 1,166 Votes: 0 Revisions: 5

Overview

Comparison criteria is not working for Cisco ASA as configured below. 

^:Written by

 

As a result, NCM is still showing the line in the report.

Environment

NCM 7.1 and later 

Cause 

Incomplete comparison criteria

Resolution

Correct the RegEx pattern as below:

  1. Since there is a stand alone ":" and a Stand Alone "!" and they both start at the beginning of the line, and both are part of the same 'block of the config'. It will be necessary to have Stand alone RegEx to ignore these lines

^:

^!

 

Also with these two stand alone Criteria added, any existing Comparison Criteria starting with a ":" or a "!" should be disabled or removed, since the two newly added will by default ignore any line starting with a ":" or "!", regardles of what follows

          

 

 

Last modified

Tags

Classifications

Public