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Home > Success Center > Network Configuration Manager (NCM) > Cannot download a configuration from a Gigamon device

Cannot download a configuration from a Gigamon device

Created by Bill Corgey, last modified by MindTouch on Jun 23, 2016

Views: 844 Votes: 0 Revisions: 6

Overview

NCM does not save the configurations for some versions of Gigamon devices.

Environment

  • Device: Gigamon (1.3.6.1.4.1.26866.3.6)
  • All NCM versions

Cause 

In some versions and models (not all have been determined at this point) at the end of the configuration, the device will send a string of characters (ESC[KESC[?1lESC>), and causes NCM to remove the first letter of the host name. This will result in the actual prompt as shown in NCM to be different than the initial prompt. The match of the prompt is what would signal NCM that the configuration has completed and then to save and disconnect.

Resolution

  1. Depending on the NCM version, use the relevant steps to add the following template. For information, see the Creating and Modifying Templates in the NCM Administrator Guide.
  2. Use the following lines as the actual content of the template:
    <Configuration-Management Device="GigamonV3" SystemOID="1.3.6.1.4.1.26866.3.6">
        <Commands>
          <Command Name="ALLOCATEPTY" Value="True" />
          <Command Name="MENUBASED" Value="False" />
          <Command Name="RESET" Value="terminal length 999" />
          <Command Name="DOWNLOADCONFIG" Value="show run${CRLF}${CRLF}${CRLF}" />
          <Command Name="UseMultipleDownloadCommands" Value="True"/>
          <Command Name="Version" Value=""/>
        </Commands>
    </Configuration-Management>

 

Last modified
21:02, 22 Jun 2016

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