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Home > Success Center > Network Configuration Manager (NCM) > CPU is 100% utilized after upgrading to NCM 7.6

CPU is 100% utilized after upgrading to NCM 7.6

Updated 25 July 2017 

Overview

Main poller or Additional NPM servers are having CPU issues, hitting 100% and locking up the servers.
 

The CPU is overutilized to 100% by SWJobEngineWorker2.exe process after midnight.

  • This issues happened many times on main poller or one of your additional pollers.
  • issue have been occurring since we upgraded NPM to 12.1 and NCM 7.6.
  • All NPM, NCM and Orion platform hotfixes is installed.
  • The workaround solution is reboot server or restart all Solarwinds services. 

 

Environment

  • NPM 12.1
  • NCM 7.6
  • NTA 4.2.2
  • Core 2017.1.3 SP3

Cause 

  • Caused by upgrade to NCM 7.6, NPM 12.1, NTA 4.2.2, Core 2017.1.3 SP3
  • Mainly due to environment having dozens of NCM nightly dwnload config jobs.
  • This couple with NCM change to its schedule download jobs, in that it now handles jobs better in smaller numbers.

Resolution

  • Reduce number of NCM Jobs from many to few.
  • For example for 40 jobs, 1 per vendor, to a few large jobs.
  • Say 1 job for Cisco and one for everything else.
  • NCM 7.6 handles this better as it increased the Simultaneous Downloads from 8 to 25.
  • If your not set to 25, then edit it under NCM Settings.
 

 

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