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Home > Success Center > Netflow Traffic Analyzer (NTA) > Unable to open connection to the NTA Flow Storage Database

Unable to open connection to the NTA Flow Storage Database

Updated June 29th, 2018

Overview

ISSUE:

Unable to connect to the NTA Flow Storage Database (FSDB) when running the Configuration Wizard.

 

ERROR:

NTA BusinessLayer logs

ERROR SolarWinds.Netflow.Processing.Workflow.NetFlowPacketWorkflowManager - Error flushing data
System.ServiceModel.CommunicationException: Could not connect to net.tcp://<FSDB server>:17777/orion/nta/FlowStorageService. The connection attempt lasted for a time span of 00:00:00. TCP error code 10048: Only one usage of each socket address (protocol/network address/port) is normally permitted <FSDB IP address>:17777.  ---> System.Net.Sockets.SocketException: Only one usage of each socket address (protocol/network address/port) is normally permitted <FSDB IP address>:17777

 

Note:  TCP error code 10048: Only one usage of each socket address (protocol/network address/port) is normally permitted

Environment

  • NTA 4.0 - NTA 4.2.3

Cause 

Unable to open port to connect to the NTA Flow Storage Service.

This is an environmental issue.

Resolution

Complete the following steps to add or modify the following registry keys on the Orion servers and the NTA Flow Storage DB server:

  • HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\TCPIP\Parameters\MaxUserPort = 60000
  • HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\TCPIP\Parameters\TcpTimedWaitDelay = 30

 

SolarWinds strongly recommends that you back up your registry before making any edits to your system registry. You should only edit the registry if you are experienced and confident in doing so. Using a registry editor incorrectly can cause serious issues with your operating system, which could require you to reinstall your operating system to correct them. SolarWinds cannot guarantee resolutions to any damage resulting from making registry edits.

 

  1. To open the Registry, choose Start -> Run -> Regedit.
  2. Expand HKEY_LOCAL_MACHINE -> SYSTEM -> CurrentControlSet -> Services -> TCPIP.
  3. Select Parameters.
  4. Click Edit -> New ->DWORD (32-bit) Value.
  5. Set the name MaxUserPort and the value to Decimal 32768.
  6. Select Parameters.
  7. Click Edit -> New ->DWORD (32-bit) Value.
  8. Set the name TcpTimedWaitDelay and the value to Decimal 30.
  9. Save your changes.
  10. Reboot the server

 

Once this is done the issue will be resolved.

 

 

 

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