Submit a ticketCall us

WebinarUpcoming Webinar: How Help Desk and Remote Support Pays for Itself

Learn how help desk software can simplify ticketing management, allow you to track hardware and software assets, and accelerate the speed of IT support and service delivery. Gain insights on how remote support tools allow your IT team to maximize their efficiency and ticket resolution by expediting desktop troubleshooting, ultimately helping keep end-users happy and productive.

Register here.

Home > Success Center > Netflow Traffic Analyzer (NTA) > Error flushing data System.ServiceModel.FaultException: Exception 'InvalidOperationException' while resolving string IDs: Can't get IDs for strings becaues connection can't be opened

Error flushing data System.ServiceModel.FaultException: Exception 'InvalidOperationException' while resolving string IDs: Can't get IDs for strings becaues connection can't be opened

Updated April 29th, 2016

Overview

This article addresses an error in the Orion Web Console that it is unable to communicate with the NTA.BusinessLayer:

ERROR:

SolarWinds.Netflow.Processing.Workflow.NetFlowPacketWorkflowManager - Error flushing data
System.ServiceModel.FaultException: Exception 'InvalidOperationException' while resolving string IDs: Can't get IDs for strings becaues connection can't be opened.

Environment

  • NTA 4
  • NPM 11

Cause 

This occurs when the NetFlow service is corrupted or is not installed, or when the Primary Polling Engine or Additional Polling Engine is not using the proper connection string to the SQL database server (which can occur after a migration).

Resolution

  • Repair the NTA service. The Configuration Wizard should automatically launch after the repair. Otherwise, manually launch the Configuration Wizard.

Note: Refer to Multiple running ConfigWizard instances detected! if you run into this error.

  • Please run the Configuration Wizard using the "Database" option in order to make sure the database connection string points to the correct SQL database:

https://support.solarwinds.com/Success_Center/Network_Performance_Monitor_(NPM)/Running_Configuration_Wizard

Last modified

Tags

Classifications

Public