Submit a ticketCall us

Welcome to the NEW Success Center. Search all resources (documentation, videos, training, knowledge base articles) or browse resources by product. If you are unable to find what you are looking for, please contact us at customersuccess@solarwinds.com

 

 

 

 

Home > Success Center > Netflow Traffic Analyzer (NTA) > Corrupted performance counters

Corrupted performance counters

Table of contents

Issue

Corrupted performance counters prevent precise troubleshooting of SolarWinds NetFlow Service or NTA Flow Storage Service.

Cause

Performance counters have been corrupted (initialized as read-only). 

To verify the cause of the issue:

  • Check NTA.BusinessLayer.log or FastBitServerService.log, and if there is the following error message, your service crashes because of corrupted counters.

    ERROR SolarWinds.Orion.NetFlow.Service.Program - NetFlowService will be abnormally terminated - Unhandled exception. System.InvalidOperationException: The requested Performance Counter is not a custom counter, it has to be initialized as ReadOnly. at System.Diagnostics.PerformanceCounter.InitializeImpl() at System.Diagnostics.PerformanceCounter..ctor(String categoryName, String counterName, String instanceName, Boolean readOnly) at System.Diagnostics.PerformanceCounter..ctor(String categoryName, String counterName, Boolean readOnly) at FastbitCLR.PerfCounterSampling.Initialize() at SolarWinds.Netflow.FastBit.Server.Core.FastBitEmbeddedConnection.StartSamplingPerformanceCounters() at SolarWinds.Netflow.FastBit.Server.Api.NTAFastBitServerPlugin.InitializeFastBitDatabase() at SolarWinds.Netflow.FastBit.Server.Api.NTAFastBitServerPlugin.Start() at SolarWinds.Netflow.Processing.AppContext.b__a() at System.Threading.ExecutionContext.Run(ExecutionContext executionContext, ContextCallback callback, Object state, Boolean ignoreSyncCtx) at System.Threading.ExecutionContext.Run(ExecutionContext executionContext, ContextCallback callback, Object state) at System.Threading.ThreadHelper.ThreadStart()

  • Open Windows Performance Monitor (for example by entering perfmon into the Command Prompt) and navigate to Performance Monitor. In cas of performance counters, an error message displays, such as: "MMC cannot initialize the snap-in performance monitor".

Resolution

You need to reset performance counters. To do so:

  1. Open the Command Prompt using an account with administrator rights.
  2. Change the directory according to your operating system:

    For 32-bit operating systems, type:  c:\windows\system32 

    For 64-bit operating systems, type: cd c:\windows\sysWOW64 
  3. Run lodctr /r.
  4. Restart the appropriate service (SolarWinds NetFlow or NTA Flow Storage service).
Last modified
14:08, 13 Nov 2015

Tags

Classifications

Public