Submit a ticketCall us

Welcome to the NEW Success Center. Search all resources (documentation, videos, training, knowledge base articles) or browse resources by product. If you are unable to find what you are looking for, please contact us at customersuccess@solarwinds.com

 

 

 

 

Home > Success Center > Netflow Traffic Analyzer (NTA) > Core Businesslayer Plugin on APE not loading after installing NTA 4.0 or 4.1

Core Businesslayer Plugin on APE not loading after installing NTA 4.0 or 4.1

Created by Matthew Lamb, last modified by MindTouch on Jun 23, 2016

Views: 722 Votes: 0 Revisions: 4

Overview

 

When attempting to upgrade or install NTA 4.1 or lower (v4) onto the primary poller, the Core Businesslayer Plugin fails to load. Indications in the BusinessLayerHost.log give a FATAL error when attempting to load the plugin:

 

2015-12-11 08:49:43,888 [7] ERROR SolarWinds.Orion.Common.SWEventLogging - Unhandled Exception caught in Core Service Engine startup. RunQuery failed, check fault information.
2015-12-11 08:49:43,888 [7] FATAL SolarWinds.Orion.Core.BusinessLayer.CoreBusinessLayerPlugin - Unhandled Exception caught in plugin startup.
System.ServiceModel.FaultException`1[SolarWinds.InformationService.Contract2.InfoServiceFaultContract]: RunQuery failed, check fault information. (Fault Detail is equal to InfoServiceFaultContract [ System.NullReferenceException: Object reference not set to an instance of an object.
   at SolarWinds.Data.Query.Processor.StorageTranslator.TryMakeStorageExpression(EntityExpression conceptualEntityExpression, IMappingFragment mappingFragment, SwqlExpression& storageExpression)
   at SolarWinds.Data.Query.Processor.StorageTranslator.HandlePropertyFromEntityWithSinglePartitions(IEntityTypeMapping entityMapping, EntityExpression conceptualEntityExpression)
   at SolarWinds.Data.Query.Processor.StorageTranslator.HandleProperty(EntityExpression entityExpression)
   at SolarWinds.Data.Query.Processor.StorageTranslator.Visit(ColumnExpression column)
   at SolarWinds.Data.Query.Swql.ParseTreeDuplicatorNoState.Visit(SelectClause select)
   at SolarWinds.Data.Query.Processor.StorageTranslator.Visit(SelectStatement statement)
   at SolarWinds.Data.Query.Processor.StorageTranslator.Process(SelectStatement statement)
   at SolarWinds.Data.Query.Processor.PreProcessor.ProcessInternal...).

Environment

  • NPM 11+
  • NTA v4 to v4.1

 

Cause 

This is a known bug that occurs in this version where the patch files applied normally to the primary poller have also been applied to the APE.

Resolution

This issue has been resolved in NTA Primary and APE version 4.1.1. If you are unable to upgrade, remove the schemas affecting the APE:

Warning: 

  • Save a copy of the original files to your local drive as a backup file, in case you need to rollback later.
  • SolarWinds strongly recommends that you only edit the following files as instructed. Any additional modifications may result in system performance issues or may create an error state.

1. Stop NetFlow Service and information services on all pollers.
2. On the APE, delete the following:

  • C:\Program Files (x86)\SolarWinds\Orion\Information Service\3.0\SolarWinds.Data.Providers.Orion.Netflow.FastBit.dll
  • C:\Program Files (x86)\SolarWinds\Orion\Information Service\3.0\Schemas\NetflowFastBitSchema.xml
  • C:\Program Files (x86)\SolarWinds\Orion\Information Service\2.0\SolarWinds.Netflow.Reporting.dll

3. Start NetFlow service and information services.

 

 

Last modified
20:29, 22 Jun 2016

Tags

Classifications

Public