Submit a ticketCall us

Webinar: Web Help Desk for HR, Facilities and Accounting Departments
This webinar will focus on use cases for HR, Facilities and Accounting.

Having a unified ticketing and asset management system for all the departments in your company can provide end-users with a seamless experience and make things easier for your IT team. Yet, with different business tasks and objectives, many departments don’t fully understand the capabilities of Web Help Desk and how the software can be customized for effective use in their departments.
Register Now.

Home > Success Center > Netflow Traffic Analyzer (NTA) > Cannot upgrade the NTA Flow Storage Database installed on an Additional Polling Engine

Cannot upgrade the NTA Flow Storage Database installed on an Additional Polling Engine

Overview

When you upgrade your SolarWinds NTA software, the following message may appear:

Cannot upgrade NTA because the remote NTA Flow Storage Database has not been upgraded yet. 

This error message is addressed in this KB article. When you follow the article procedures, you may attempt to upgrade the NTA Flow Storage Database (FSDB) using the same installer. During the installation, a similar message displays stating that NTA is at a prior version, creating an endless procedure loop.

Environment

  • All Orion NTA 4.x environments

Cause 

The installer needs to run in /StorageOnly mode to specify the NTA FSDB as the intended upgrade target.

Resolution

 

It is preferred to migrate the NTA FSDB to a dedicated server and not the Additional Polling Engine. As of NTA 4.2, the NTA Flow Storage Database is no longer supported on additional pollers or additional websites and needs to be installed on a dedicated server.

See this KB article for general installation instructions. 

 

Check the file C:\ProgramData\Solarwinds\Logs\NTA\Installer\NTA_X.X.X_MSI_Install_Log.txt for an entry

NTA [10:16:14: 35] : INFO  ..PreInstallChecker returned -1
NTA [10:16:14: 66] : FAIL  .. ..Failed to determine action from PreInstallChecker.exe file.
NTA [10:16:14: 97] : Exit  .. GetNtaMsiPackageName FAILED
NTA [10:16:14:128] : FAIL  ..Failed to get NTA MSI package name.

 

Then download the install package fresh from the Customer Portal and try again.

 

 

Last modified
09:11, 15 Mar 2017

Tags

Classifications

Public