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Home > Success Center > Netflow Traffic Analyzer (NTA) > Cannot connect to NTA Flow Storage Database

Cannot connect to NTA Flow Storage Database

Updated November 2, 2016

Overview

This article provides troubleshooting steps when you are unable to upgrade NTA after upgrading NPM from 11.5.x to 12.0 on the Primary Orion Server.

The following error appears during the upgrade:

Cannot connect to NTA Flow Storage Database.

Please make sure that:

* NTA Flow Storage Database is installed and configured on the server.

* You can reach the server.

* No firewall is blocking the connection.

 

Environment

  • NPM 12.0
  • NTA 4.2.0

Cause 

This can be caused by the NTA Flow Storage Service on the Flow Storage Database stopping or not responding.

Resolution

  1. Remote in to the NTA Flow Storage Database.
  2. Open Services (Start > Run > Services.msc).
  3. Verify that Solarwinds Netflow Flow storage service is present and running.
  4. Run the NTA Configurator (Start > Search Netflow Storage Configurator).
  5. Check where the NTA data are being stored.
  6. Verify that there is enough free space on the drive where the Netflow data are stored.
  7. On the NTA Configurator, click TEST Connection and click OK.
  8. Go back to the Primary Orion Server and re-run the NTA upgrade.

 

Note: It is highly recommended to install the NTA 4.2 Hotfix on the Flow Storage Database Server as this addresses the issue with the NTA Flow Storage Service.

 

In some instances, you will need to reboot the NTA Flow Storage Server before the Primary Polling Engine can connect to the database.

 

Last modified
17:11, 1 Nov 2016

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