Submit a ticketCall us

Looking to compare latest NPM features with previous versions of NPM?
The NPM new feature summary offers a comparison of new features and improvements offered with this release.

 

Home > Success Center > Log & Event Manager (LEM) > Some agent nodes are duplicated and show as a non-agent node

Some agent nodes are duplicated and show as a non-agent node

Created by Jason Dee, last modified by MindTouch on Jun 23, 2016

Views: 43 Votes: 4 Revisions: 6

Overview

In your LEM Console, you see agent nodes that appear to have duplicate non-agent nodes (signified by a Y-shaped grey icon in the Status tab).

Environment

  • All LEM versions
  • Windows or Linux hosts with more than one IP address or network interface

Cause 

Usually, instances of one or more agents showing up as a non-agent node (or as both an agent and non-agent node) is due to having multiple network interfaces and/or IP addresses on the same host.

Resolution

Warning:

  • Consult your System Administrator before performing the following procedure.
  • SolarWinds strongly recommends that you only edit the spop.conf file as instructed. Any additional modifications may result in system performance issues or may create an error state.
  • Save a copy of the original spop.conf file to your local drive as a backup file, in case you need to roll back later.
     

​Connect to the affected host and perform the following steps:

  1. Stop the SolarWinds Log and Event Manager Agent service.
     
  2. Go to C:\Windows\system32\ContegoSPOP (32-bit) or C:\Windows\SysWOW64\ContegoSPOP (64-bit) and locate spop.conf.
     
  3. Open spop.conf in a text editor.
     
  4. Add one of the following attributes on a new line:
    1. ​To force the agent to use the hostname (as shown by typing hostname in a command prompt): 
      UseLocalEnvironmentVariableForLocalHost=true
    2. To force the LEM manager to use the hostname that the LEM detects for this host:
      UseManagerDetectionOfLocalHost=true
    3. To force the agent to use the IP address you specify:
      ForcedLocalAddress=10.10.10.1 (use the IP address you prefer for this host)
       
  5. Save and exit.
     
  6. Start the SolarWinds Log and Event Manager Agent service.
     
  7. After the agent reconnects, the duplicate node should be removed automatically.
Last modified
20:22, 22 Jun 2016

Tags

Classifications

Public