Submit a ticketCall us

Don’t fall victim to a ransomware attack
Backups are helpful, but sometimes that’s not enough to protect your business against ransomware. At our live webcast we will discuss how to protect against ransomware attacks with SolarWinds® Patch Manager and how to leverage log data to detect ransomware. Register now for our live webcast.

Home > Success Center > Log & Event Manager (LEM) > Log and Event Manager (LEM) 6.3.1 Hotfix 4 ReadMe

Log and Event Manager (LEM) 6.3.1 Hotfix 4 ReadMe

LEM 6.3.1 Hotfix 4 Release Date: March 30, 2017

ReadMe File Updated: March 30, 2017

The ReadMe for the latest LEM 6.3.1 Hotfix is available here.

This hotfix can be downloaded from your Customer Portal.

Notes

  • This hotfix cannot be uninstalled.
  • This release includes the latest LEM Manager and LEM Agent updates:
    • ​​​​​LEM Manager hotfix 4
    • LEM Agent hotfix 4
  • For information about the security issues fixed in Hotfix 4, see this THWACK! announcement: 
    LEM V6.3.1 HOT FIX 4 IS NOW AVAILABLE

Fixed issues

This is a cumulative hotfix that includes fixes from Hotfix 1, Hotfix 2, and  Hotfix 3.

Hotfix 4 addresses the following issues:

  • LEM Manager: Addressed several security issues.
  • LEM Manager: Made multiple updates that improve communication with the LEM Agent.
  • LEM Manager: Fixed an issue related to free disk space management. Previously LEM would under-report the amount of disk space remaining if raw logging was enabled.
  • LEM Manager: Updates that improve the performance of some connectors. In addition, fixed a bug that caused a connector to not function properly.

The following fixes from Hotfix 1, Hotfix 2, and Hotfix 3 are also included in this Hotfix:

  • LEM Manager: Fixed a CMC command vulnerability.
  • LEM Manager: Scheduled nDepth search: results limited to 50.000.
  • LEM Manager: Fixed ImportCert error when importing certificate after command failure.
  • LEM Manager: Fixed an issue that display the IP address instead of the FQDN/hostname in "All Installed Agents."
  • LEM Manager: Fixed an issue when an L4 Database appliance started with only 128MB of memory.
  • LEM Manager: Updates the Java platform to the latest version.
  • LEM Manager: Fixed an out-of-memory issue that occurs when sending alerts to the console. The fix improves performance when a large number of events are sent to the console.
  • LEM Manager: Fixed agent-manager communication issues: periodic disconnect and others.
  • LEM Manager: Fixed an issue with nDepth log retention (logging missing date in raw records).
  • LEM Manager: Fixed an issue that prevents logging in to LEM if using UserPrincipalName with a custom Alias or SAMAccountName with NETBIOS.
  • LEM Manager: Added the ability to use sub-alias LDAP environments.
  • LEM Manager: Removed field limitations in the normalized alert database.
  • LEM Manager: Fixed a log rotation issue that causes connectors to stop working if log lines are too long.
  • LEM Manager: Fixed a single sign-on (SSO) issue that occurs if a Kerberos ticket is unusually long because a user belongs to many groups.
  • LEM Manager: Added the ability to configure custom LDAP groups for authentication.
  • LEM Manager: Set an agent memory limit for agents upgraded from older versions.
  • LEM Manager: Fixed other agent-manager communication issues.
  • LEM Manager: Additional improvements to assist customer support, including improved logging, and added diagnostics.
  • LEM Manager: The threat-feeds server certificate changed. LEM cannot download thread-feeds IPs.
  • LEM Manager: Unable to use a domain containing a dash in the LDAP configuration.
  • LEM Manager: Unable to recover a password when HTTP is disabled.
  • LEM Manager: Exceptions during a fast evaluation are not logged.

Environment

This hotfix includes updates to the SolarWinds LEM Virtual Appliance (Hotfix 4) and the LEM Agents (Hotfix 4). 

  • To Install Hotfix 4 on the LEM Appliance:
    Verify that the LEM Appliance is running release 6.3.1, 6.3.1 HF1, 6.3.1 HF2, or 6.3.1 HF3. (Verification steps are provided in the next section.) Following verification, complete the steps in the INSTALL HOTFIX 4 ON THE LEM MANAGER section.
     
  •  To install Hotfix 4 on the LEM Agents:
    Use one of the following methods:
    • Use the auto-upgrade feature to automatically upgrade Agents if the feature is enabled.
    • If the auto-upgrade feature is disabled, or if there are communication issues between agents and the LEM Manager, follow the manual installation steps included in the INSTALL HOTFIX 4 ON AGENTS (MANUAL STEPS) section of this ReadMe.

    If upgrading older agent versions, the agent is first upgraded to version 6.3.1, and then to version 6.3.1.hotfix4.

Verify the LEM appliance release version

  1. Open the LEM console and log in to the LEM Virtual Appliance.

  2. Click Manage > Appliances.

  3. Under the Version column, check the current LEM version. 

  • If the version is Release 6.3.1, 6.3.1 HF1, 6.3.1 HF2, or 6.3.1 HF3, install the hotfix. Go to the next section: Install Hotfix 4 on the LEM Manager.
  • If the version is not Release 6.3.1, 6.3.1 HF1, 6.3.1 HF2, or 6.3.1 HF3, do not install the hotfix.

Install Hotfix 4 on the LEM Manager

  1. Using the LEM Console or an SSH client (such as PuTTY), log in to CMC and do the following:

    1. At the cmc> prompt, enter:

      manager

    2. At the cmc::manager# prompt, enter:

      hotfix

  2. Follow the instructions on your screen, providing the network path to your Hotfix 4 files and the appropriate credentials with Read access to this path.

    For example:

    \\server\share\unzipped_hotfix_folder\hotfix

    If you receive a message stating that no upgrades were found, ensure that you entered the correct path to the files.

    When completed, a CMC: prompt appears.

  3. Reboot the appliance:

    1. Exit the cmc::manager# prompt or at the cmc# prompt, enter:

      appliance

    2. At the prompt, enter:

      reboot

  4. After the appliance reboots, log in to CMC.

    At the prompt, enter:

    manager

  5. At the prompt, enter:

    viewsysinfo

    The system info appears on your screen.

  6. At the top of your screen, the following message should appear if the hotfix was installed correctly:

           SolarWinds manager version is: 6.3.1
           SolarWinds manager build is: hotfix4

    Hotfix 4 is installed on LEM Manager.

Install Hotfix 4 on the Agents (Manual Steps)

Use these steps to apply Hotfix 4 to the agents if the auto-upgrade feature is turned off, or if there are communication issues between the agents and the LEM Manager. These steps are only valid if the agent was not previously auto-upgraded to version 6.3.1.hotfix2.

  1. Copy the included agentUpgrade_6.3.1.hotfix4.zip file to the agent machine.
  2. Extract the contents of the ZIP file to any folder. 
    The extracted archive contains 8 JAR files and 2 BAT files. 
  3. Install Hotfix 4 on each agent using one of the following methods:
    • If upgrading a Windows agent, do the following:
      1. Right-click the installAgentUpgrade_6.3.1.hotfix4.bat file and choose "Run as administrator."
    • To install the upgrade manually:
      1. Stop the agent service.
      2. Back up the replaced *.jar files in the ContegoSPOP/6.3.1/jars folder.
      3. Replace the *.jar files with the new versions from the ZIP file.
      4. If you are installing a Windows agent, then copy the collectLogs.bat file to the ContegoSPOP folder.
      5. Start the Agent service.
  4. Verify that the agent was successfully upgraded:
    1. Log in to the LEM console and choose Manage > Nodes. 
      The Nodes table opens. 
    2. Verify that the Version column shows 6.3.1.hotfix4 for upgraded agents.

Uninstalling Hotfix 4

Hotfix 4 cannot be uninstalled. If you have any problems with hotfix 4, contact SolarWinds Technical Support at www.solarWinds.com/company/contact-us.

Last modified
11:33, 30 Jun 2017

Tags

Classifications

Public