Submit a ticketCall us

Get a crash course on Network Monitoring delivered right to your inbox
This free 7-day email course provides a primer to the philosophy, theory, and fundamental concepts involved in IT monitoring. Lessons will explain not only how to perform various monitoring tasks, but why and when you should use them. Sign up now.

Home > Success Center > Log & Event Manager (LEM) > LEM Remote Agent deployment using Patch Manager issue

LEM Remote Agent deployment using Patch Manager issue

Updated June 19, 2017

Overview

This article describes issues and limitations during remote deployment of LEM Agent using a patch management solution either from SolarWinds Patch Manager or from a third party patch management vendor.

 

For example, The following issues occurred when vendor QDP is deployed using the LEM local agent installer with -i silent switch.

  • The LEM Agent was deployed but the node is not displayed in the Manager Console and the Agent log indicates that it is unable to bind to 127.0.0.1:xxxxx. This is because the installer.properties file was not copied to the local machine and it instead created a temporary location there the files were copied. 
    (Wed Jun 14 13:56:58 BST 2017) EE:ERR [Communications] {ComModuleSpop:21} IP is null so cannot open connection to parent
    (Wed Jun 14 13:57:38 BST 2017) II:INFO [AgentMessageCentralImpl] {XML Communication Reconnector - 1:40} Trying to establishing connection from the Agent to the Manager on localhost/127.0.0.1:xxxxx
    (Wed Jun 14 13:57:39 BST 2017) WW:WARNING [AgentMessageCentralImpl] {XML Communication Reconnector - 1:40} Unable to establishConnection with the Manager. Reason java.net.ConnectException: Connection refused: no further information: localhost/127.0.0.1:37891
  • Permissions and local policy settings have been exhausted on the agent machine deployed. 
  • Uninstalled and re-deployed via the QDP console and it resulted in the same issue.
  • Installing the agent locally works.

Environment

  • All LEM versions
  • LEM Agent 6.3.1

Cause 

This is caused by multiple environmental issues depending on the vendor used.

Resolution

 

Perform the following workaround during the deployment:

  1. Select the local agent .exe file and add the -i silent switch.
  2. Download and save the installer.properties file in the same folder where the .exe file is located.

 

Last modified
16:58, 19 Jun 2017

Tags

Classifications

Public