Submit a ticketCall us

AnnouncementsTHWACKcamp 2018 is here

2018 is the seventh year for THWACKcamp™, and once again we’ll be live October 17 – 18 with packed session tracks covering everything from network monitoring and management, to change control, application management, storage, cloud and DevOps, security, automation, virtualization, mapping, logging, and more.

Register for online sessions.

Home > Success Center > Log & Event Manager (LEM) > LEM - Knowledgebase Articles > nDepth query not returning correct results when using multiple NOT conditions

nDepth query not returning correct results when using multiple NOT conditions

Updated August 21, 2017

Overview

Sometimes when using multiple NOT conditions for the same field in an nDepth search query, it will ignore all of the NOT conditions and return all results.

 

Environment

  • LEM all versions

 

Cause 

The cause is unknown at this time.

 

Resolution

The current workaround for this issue is to create a new User Defined Group and add all of the conditions that you were using a NOT operand for in nDepth. You can then adjust your query in nDepth to use only one NOT condition and have it reference the UDG you created.

 

  1. Go to Build > Groups, click the + sign, and choose User Defined Group.
  2. Add all of the individual data points you want to search for into the Name and Data fields one per line. Click Save on the bottom right when finished.
  3. Go back to nDepth and delete all but one NOT condition.
  4. Expand User-Defined Groups on the left side and drag the new group you created to the right side of your NOT condition.
  5. Perform your search again and the correct results should be returned.

 

 

 

 

Last modified

Tags

Classifications

Public