Submit a ticketCall us

WebinarDatabase Roundtable – Expert Database Professionals Feel Your Pain

In this video broadcast, Head Geek™ Tom LaRock is joined by Karen Lopez, Tim Chapman, and David Klee. They’ve known each other for many years, so this discussion was like four friends getting together to talk data and databases. They discussed diagnostic data collection, common performance root causes, reactive tuning versus proactive, and more. Join us for an engaging discussion on these topics! Plus, Tom LaRock will be available to answer your questions live.

Register now.

Home > Success Center > Log & Event Manager (LEM) > LEM - Knowledgebase Articles > LEM filter does not trigger with User Defined Group condition

LEM filter does not trigger with User Defined Group condition

 

Overview

Attempting to create a filter, where a User-Defined Group is used.

For example, UserLogOff.DetectionIP = GroupTest

Where Group Test has a list of computer names to compare in the condition.

However, no events appear in the new filter.

Environment

LEM 6.3.1

Cause 

If the symbol * is missing, then the condition in the filter will not work.

Resolution

  1. As a test, create a filter that has only one of the servernames within the condition.

    Example: UserLogOff.DetectionIP = *ComputerA*

    Where ComputerA is one of the names that is in the User-Defined Group: GroupTest

    Make sure that this condition works.

  2. If the condition works, then check the column DATA in the User-Defined Group. In this case the GroupTest may only have in the data section: ComputerA. Which is not correct. The data portion should have: *ComputerA*     
  3. Edit the entries in the User-Defined Group, and add the * symbol before and after your data parameters.
  4. Save the changes to your group, and then check on the filter again. User should see that the events have started coming in.

 

Last modified

Tags

Classifications

Public