Submit a ticketCall us

AnnouncementsAre You “Flying Blind?”

When it comes to your complex IT infrastructure, you want to ensure you have a good grasp of what’s going on to avoid any fire drills that result from guesswork. Read our white paper to learn how proactively monitoring your IT environment can help your organization while giving you peace of mind.

Get your free white paper.

Home > Success Center > Log & Event Manager (LEM) > LEM - Knowledgebase Articles > LEM Reports Console Error: Logon failed. Error code: -2147189176

LEM Reports Console Error: Logon failed. Error code: -2147189176

Updated: February 5, 2019

Overview

This article provides brief information and steps to resolve the issue when the installation and set up of LEM Reports is unsuccessful. The following error appears when running a report:

Details: [Database Vendor Code: -1305]

Logon failed. Error code: -2147189176

 

Environment

All LEM versions

Cause

  • Reports Console version do not match the version of the LEM appliance
  • Improper credentials used in the Reports configuration
  • Reports Console was not installed using Run as administrator
  • Firewall or anti-virus/anti-malware interference
  • TLS was enabled on DB and no cert was imported in LEM Reports console

Resolution

  1. Save any Custom Reports you have in the location below:

    C:\Program Files (x86)\SolarWinds Log and Event Manager Reports\CustomReports

  1. Uninstall both Log and Event Manager Reports Console and Crystal Reports v11 Runtime from the host machine.
  2. Download a version of Crystal and LEM reports similar to your LEM appliance installed. 
    1. Log in to your Customer Portal and download the installation files for Crystal and LEM Reports.
    2. Right click on Run as administrator to install Crystal and LEM Reports.  See table below:
Appliance
Reports

6.1.0

6.1.x.x

6.0.1

6.0.1.x

6.0.0

6.0.0.x

5.7.0

5.7.x.x

5.6.0

5.6.x.x

 

  1. After installation, configure LEM Reports to be launched as an administrator.
    1. Right-click Reports, and then select Properties.
    2. Select Compatibility. 
    3. Select Run as an administrator, and then click OK.
  2. Remove restrictions on LEM Reports. Use an SSH client or VMware console to connect to your LEM appliance.
    1. Connect to port 32022 when using SSH client. Log in with your CMC account.
    2. Enter Service for the manager sub-menu.
    3. Enter unrestrictreports.

 Check that port 9001 is open between the client where you just installed LEM Report and LEM appliance.

  1. Enable logging for LEM Reports after installation.
    1. Right-click Reports, and then select Properties.
    2. In the Shortcut tab, add /L at the end of the Target line. The outcome should reflect below:

      C:\Program Files (x86)\SolarWinds Log and Event Manager Reports\SWLEMReports.exe/L

 

Test the LEM Report

Launch the newly installed LEM Reports.

For versions 6.0.0 and earlier:

  1. Enter the IP address or hostname of your LEM in the connection window.
  2. Click Add Manager, and then click Close.

For versions 6.0.1 and later:

  1. Log in to your web console.
  2. Click the green to add the manager and credentials information to your LEM Reports software.
  3. Click Close.

You should now be able to run LEM Reports. 

If the issue is not solved, raise a ticket to the help desk and include the log file below:

C:\Program Files (x86)\SolarWinds Log and Event Manager Reports\SWLEMReports.log

 

 

Last modified

Tags

Classifications

Public