Submit a ticketCall us

whitepaperYour VM Perplexities Called, and They Need You to Read This.

Virtualization can give you enormous flexibility with future workloads and can be a key enabler for other areas, like cloud computing and disaster recovery. So, how can you get a handle on the performance challenges in your virtual environment and manage deployments without erasing the potential upside? Learn the four key areas you need to be focusing on to help deliver a healthy and well-performing data center.

Get your free white paper.

Home > Success Center > Log & Event Manager (LEM) > LEM - Knowledgebase Articles > Error 1939.Service “ (TriGeoMSSQLAuditor) could not be configured

Error 1939.Service “ (TriGeoMSSQLAuditor) could not be configured

Created by Justin Rouviere, last modified by MindTouch on Jun 23, 2016

Views: 1,332 Votes: 1 Revisions: 7

Overview

The following error message appears when installing or uninstalling MSSQL Auditor:

Error 1939.Service “ (TriGeoMSSQLAuditor) could not be configured. This could be a problem with the package or your permissions. Verify that you have sufficient privileges to configure system services.

1939 error.jpg

Environment

LEM Agents with MSSQLAuditor installed.

Cause

This is a permission issue with the Program Files (x86) folder where an admin use is not able to write to the folder. This can be verified by attempting to add the specific user under the Security tab with full permissions.

Resolution

  1. Clear the registry entry that is preventing the completion of the uninstallation.
  2. Start regedit.
  3. Navigate to HKEY_CLASSES_ROOT/Installer/Products.
  4. Search for Auditor and delete the console key where the Auditor info is stored.
  5. Manually delete the entire MSSQL Auditor folder in the Program Files (x86) folder.
    HKEY_CLASSES_ROOT\Installer\Products\
    5E257EDD08916A14BAD710D9947A9705.
    Note: You may also need to delete the console key in the following registry locations:
    HKLM\SOFTWARE\Classes\Installer\Features\{number}, or
    HKLM\Products\{number}\Features

The {number} is defined by the error message in the application log.

  1. Retry and reinstall/uninstall using Run as Admin.

 

Last modified

Tags

Classifications

Public