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Home > Success Center > Log & Event Manager (LEM) > LEM - Knowledgebase Articles > Agent uninstall error in LEM 6.3.1

Agent uninstall error in LEM 6.3.1

Updated: October 5, 2018

Overview

Upgrading LEM (appliance) to version 6.3.1 allows the agents to be upgraded to 6.3.1 from LEM. A bug was discovered in that prevents uninstalling the Windows agent from Windows Programs and Features.

Error message:

Could not find a valid Java virtual machine to load.
You may need to re-install a supported Java virtual machine.

 

This will be fixed in the next version of the agent.

Environment

LEM 6.3.1, and agent version 6.3.1

Cause 

The agent uninstall cannot find the new sand-boxed Java 8, so it cannot uninstall the agent.

Resolution

There are two options to resolve this:

Option 1:

  • Use the LEM remote agent un-installer, which can be performed from a separate Windows machine, or from the computer that the agent is installed on.

    -or-

  • Reinstall the agent over the top of the existing Windows agent, using the latest Windows agent installer (local installer or remote installer).
    a. Be sure to right-click the installer and select Run as administrator so the installer has the permissions to perform the un-install.
    b. Windows Programs and Features will now be able to uninstall the agent.
    Local agent installer
    Remote agent installer

Option 2:

  • Stop the LEM Agent Service on the node via Windows Service manager i,e Services.msc.
  • Delete the C:\Windows\Syswo64\ContegoSPOP.
  • Run the Remote agent installer using the Run as administrator.

 

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