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Home > Success Center > Log & Event Manager (LEM) > LEM - Knowledgebase Articles > Agent status shows connected and online but no events are being received from it

Agent status shows connected and online but no events are being received from it

Updated March 10, 2017

Overview

Under Manage > Nodes, an agent or agents show an online status with a green status icon, but when double-clicking on that node to view the status or checking the Node Health widget, you see that this node has not sent an event in for an extended period of time.

 

Note that this behavior is normal for Unix/Linux based hosts. Please refer to this article for details on that: Linux agent is connected but not sending any events.

Environment

All LEM versions

Agents installed on non-Unix based hosts

Cause 

1. The agent is having a connection or a certificate verification issue.

2. Incorrect time on LEM host and guest going back few years for example

Resolution

  1. Restart the agent's service and check to see if the events are coming in:
    1. On the affected host, go to Start > Control Panel > Administrative Tools > Services.
    2. Restart the SolarWinds Log and Event Manager Agent service.
    3. If events are now coming in for this host, skip the rest of these steps.
  2. Reset the agent's security certificate and re-check:
    1. On the affected host, go to C:\Windows\system32\ContegoSPOP\spop (32-bit) or C:\Windows\SysWOW64\ContegoSPOP\spop (64-bit).
    2. Delete the three .xml files and the three .trigeo files.
    3. Restart the agent's service as in step 1 above.
    4. Go to Manage > Nodes in the LEM console and delete the old, disconnected duplicate node for this host.

 

Solution for Cause#2

  1. Set correct date and time on the LEM host and Guest. Sync the guest time either with the LEM Host OR directly with NTP server but not both at same time.
  2. Restart the manager service.

 

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