Submit a ticketCall us

Don’t fall victim to a ransomware attack
Backups are helpful, but sometimes that’s not enough to protect your business against ransomware. At our live webcast we will discuss how to protect against ransomware attacks with SolarWinds® Patch Manager and how to leverage log data to detect ransomware. Register now for our live webcast.

Home > Success Center > Log & Event Manager (LEM) > Java Runtime versions for LEM Agents

Java Runtime versions for LEM Agents

Table of contents
Created by James Nielsen, last modified by Karen Valdellon on Jun 29, 2017

Views: 103 Votes: 0 Revisions: 14

Updated: June 28, 2017

Overview

This article provides information about the corresponding Java Runtime versions for LEM Agents.

Environment

  • LEM Agent 6.2 and later
  • All Windows versions

Detail

The JRE version is fixed per LEM Agent version and requires an agent upgrade to change. 

  • LEM Agent version 6.2.0 and 6.2.1 use JRE 1.7.0_80.
  • LEM Agent version 6.3.1 uses JRE 8u92.

 

It is possible to tie the agent to a local JRE installation. This can be done by changing the appropriate Java entry in the SWLEMAgent.lax file of the agent (located in the agent install directory):

 

  1. Back up the SWLEMAgent.lax file.
  2. Open the file in a text editor and edit it to point to the required JRE:
    lax.nl.current.vm=jre6.3.1/bin/java.exe

If required, it is possible to delete the JRE version directories in the ContegoSPOP directory. 

 

Note: When the agent updates the SWLEMAgent.lax file, changes may be reverted back to the agent's own JRE install. 

 

 

Last modified
18:15, 28 Jun 2017

Tags

Classifications

Public