Submit a ticketCall us

Looking to compare latest NPM features with previous versions of NPM?
The NPM new feature summary offers a comparison of new features and improvements offered with this release.

 

Home > Success Center > Log & Event Manager (LEM) > Error installing AIX agent 6.X in older versions of AIX

Error installing AIX agent 6.X in older versions of AIX

Created by Justin Rouviere, last modified by MindTouch on Jun 23, 2016

Views: 10 Votes: 0 Revisions: 4

Overview

When installing a 6.X agent in an older version of AIX, you receive a variation on the below error and the agent installer will exit:

libjvm.so preloadLibrary(/tmp/install.dir.630836/AIX/resource/jre/lib/ppc64/compressedrefs/libj9vm27.so): Symbol resolution failed for /tmp/install.dir.630836/AIX/resource/jre/lib/ppc64/compressedrefs/libj9prt27.so because:
Symbol getsystemcfg (number 163) is not exported from dependent
module /usr/lib/libc.a[shr_64.o].
Could not load module /tmp/install.dir.630836/AIX/resource/jre/lib/ppc64/compressedrefs/libj9vm27.so.
System error: Exec format error
Examine .loader section symbols with the 'dump -Tv' command.
libjvm.so failed to load: j9vm27

Environment

LEM version 6.0 or higher AIX Agent

 

Cause 

This is caused by an older version of AIX. AIX 6 TL (tech level) 7 or higher is required to run Java 7. LEM 6.0+ agents require Java 7. 

Resolution

Install an older version of the LEM Agent or upgrade the AIX server to AIX 6 TL 7 or higher.

Notes:

  • If you prefer to install an older version of the LEM Agent, you need to make sure that the agent doesn't update (such as via Global Automatic Updates.)
  • Version 5.3 and possibly 5.7 should install without this error and allow the user to connect to the LEM to send data.

 

 

Last modified
19:59, 22 Jun 2016

Tags

Classifications

Public