Submit a ticketCall us

Have You Auto Renewed? If not, you're missing out.
The SolarWinds Renewal Program comes with a host of benefits including the most recent product updates, 24/7 technical support, virtual instructor-led training and more. Experience all of this with the convenience of Auto Renewal, and never worry about missing any of these great benefits. Learn More.

Home > Success Center > Log & Event Manager (LEM) > ERROR: You must upgrade to at least 5.6.0 before upgrading to this version. Current version: 0.0.0

ERROR: You must upgrade to at least 5.6.0 before upgrading to this version. Current version: 0.0.0

Created by James Nielsen, last modified by Abdul.Aziz on Oct 26, 2017

Views: 36 Votes: 1 Revisions: 24

Overview

The following error appears while upgrading LEM:

Version.class Error.png

ERROR: You must upgrade to at least 5.6.0 before upgrading to this version. Current version: 0.0.0

Environment

LEM 6.1.0 and later upgrades

Cause

  • This error occurs when there is a direct upgrade attempt to the latest version and the recommended upgrade path was skipped
  • If there are permission issues on /tmp or corrupt data on that partition

Resolution

Issue 1 Solution:

  1. Locate the current version of the LEM:
    1. In the CMC Console, go to manager and run viewsysinfo.  
    2. In the Web or Desktop Console, go to Manage > Appliance.
  2. Download the upgrade package that matches the current version of your LEM.
  3. Extract the Trigeo and Upgrade folders to a shared folder.
  4. In the CMC Console, enter manager to go into the Manager menu.
  5. Enter scriptupgrade.
  6. Follow the prompts to specify a network share with your username and password.
  7. Once the command completes, it will return to the cmc> prompt.
  8. Confirm that the new LEM version you have downloaded is a valid upgrade path. See Upgrade path to the latest for LEM version.
  9. Enter and direct it to the network share containing the extracted folders of the LEM version you are upgrading to. It should now complete the upgrade. However, if you receive the same error message and it does not finish the upgrade, please contact SolarWinds Support.

 

Issue 2 Solution:

mgrconfig.log show this Error

/usr/local/contego/scripts/swi_login_update.pl: private subdirectory /tmp/par-root is unsafe

/usr/local/contego/scripts/swi_login_update.pl: creation of private temporary subdirectory (null) failed - aborting with errno 14.

2017-10-26 11:25:27 [upgrade.pl] Error: Cannot update swi_login template.

2017/10/26 11:25:27 [mgrconfig.pl] ERROR: sudo /usr/local/contego/scripts/upgrade.pl command returned non-zero code.

2017-10-26 11:25:27 [mountshare.sh] Running action umount  

 

Read through the error details and delete the referenced corrupt directory on /tmp

 

 

Last modified

Tags

Classifications

Public