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Home > Success Center > Log & Event Manager (LEM) > Cannot Upgrade LEM - Mount error (13)

Cannot Upgrade LEM - Mount error (13)

Created by Craig O’ Neill, last modified by MindTouch on Jun 23, 2016

Views: 236 Votes: 0 Revisions: 9

Overview

This article provides brief information and steps to resolve the following error:

Mount error (13) Permission denied. 

When upgrading from LEM 6.1  to 6.2, and a share on Windows 2012 R2 server has been created and granted all the necessary permissions, the error appears during the upgrade process. 

Environment

  • LEM version 6.1 and earlier
  • Windows 2012 R2 with enforced NTLM v2 authentication 

 

Cause 

LEM does not support NTLM v2 authentication prior to LEM v6.2.  Mount error (13) originated from Windows. Windows has issues with multi-layer paths. 

 

Resolution



The command that LEM is running (behind the scenes) is a mount -t cifs //yourserver/yourshare /tmp/smb -o user=youruser,domain=yourdomain,password=yourpassword.

Please note that mount.cifs has known issues with multi-layer share paths. 

If your share is...
 \\yourserver\yourshare\a\folder\way\down\the\line\lem\backups, mount.cifs will likely fail.

It wants to connect to \\yourserver\yourshare

If it is a requirement to send the package to the .\lem\backups folder in that example, it should share it directly so you can use the path \\yourserver\backups or (at worst) \\yourserver\lem\backups.

The command wants to mount an actual share, and struggles when the share path is buried.  If (in your example) the share is \\abc-server.domain.com\ABC, that's where the upgrade folders should be placed.
 
Otherwise, create a share at the SolarWindsLEMv6.2Upgrade level, so you can tell the upgrade mount \\abc-server.domain.com\SolarWindsLEMv6.2Upgrade

Error 13 suggests that you've got a bad username/password, but this can be misleading and often manifests as a result of an over complex path.



IF THAT STILL FAILS
 

  1. We recommend trying the following setting changes, and re-try the update.

     

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\LanmanServer\Parameters\SmbServerNameHardeningLevel
     

      add --> new DWORD value, and set to level 0 for not forcing Kerberos authentication.
     

    SmbServerNameHardeningLevel to 0  (for clients not supporting GSS (Kerberos) authentication)

    SmbServerNameHardeningLevel to 1

    SmbServerNameHardeningLevel to 2

     


    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\LSA\LmCompatibilityLevel
     

      new --> DWORD value --> enter 1  (setting to 2 forces NTLM-ver2, setting to 3 forces NTLM-ver3.



    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\LSA\SuppressExtendedProtection
     

      new --> DWORD value --> enter 0  to disable.



    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\LanmanServer\Parameters\SrvAllowedServerNames
     

      new --> multi-String --> Add the host name of the LEM in FQDN format

 

If these steps don't resolve the issue, please contact SolarWinds Support.

 

 

 

Last modified
19:55, 22 Jun 2016

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