Submit a ticketCall us

Looking to compare latest NPM features with previous versions of NPM?
The NPM new feature summary offers a comparison of new features and improvements offered with this release.

 

 

 

 

Home > Success Center > Log & Event Manager (LEM) > Applying LEM 6.2.1 - Hotfix 2

Applying LEM 6.2.1 - Hotfix 2

Table of contents
Created by Ezgi Muderrisoglu, last modified by Craig O’ Neill on Aug 24, 2016

Views: 1,327 Votes: 1 Revisions: 6

Overview

This article goes over what is included in the Hotfix 2 for LEM 6.2.1, how to download and install, and how to uninstall if needed.

Environment

LEM version 6.2.1   

Steps

NB: This Hotfix is now located in License Management → Archived Hotfixes

Log into your Customer portal.
License Management → Archived Hotfixes

 

SolarWinds® Log and Event Manager (LEM) 6.2.1 Hotfix 2
 

This is a cumulative hotfix that includes fixes from Hotfix 1.

This hotfix addresses the following issues with the LEM Manager:

* CVE-2015-3269: BlazeDS XML External Entity (XXE) vulnerability
* CVE-2015-7501: Deserialization vulnerability in the Apache® Commons-Collections
  library
* CVE-2015-7547: Debian DLA-416-1 : eglibc security update
* Unable to mount NetAPP® storage using the NT LAN Manager Security Support
  Provider Interface (NTLM-SSPI)
* Block IP Active Response does not integrate well with certain versions of Dell®
  SonicWALL
* HyperSQL Database (HSQLDB) expands up to 16GB
* Additional security fixes for the Debian operating system:
   * OpenSSH MaxAuthTries Bypass
   * DLA-91-2  : tomcat6 regression update
   * DLA-288-2 : openssh regression update
   * DLA-291-1 : libidn security update
   * DLA-305-1 : screen security update
   * DLA-309-1 : openldap security update
   * DLA-310-1 : linux-2.6 security update
   * DLA-314-1 : cups security update
   * DLA-319-1 : freetype security update
   * DLA-324-1 : binutils security update
   * DLA-325-1 : linux-2.6 security update
   * DLA-328-1 : tzdata new upstream version
   * DLA-329-1 : postgresql-8.4 update
   * DLA-330-1 : unzip security update
   * DLA-337-1 : busybox security update
   * DLA-344-1 : nspr security update
   * DLA-352-1 : libcommons-collections3-java security update
   * DLA-360-1 : linux-2.6 security update
   * DLA-364-1 : gnutls26 security update
   * DLA-368-1 : grub2 security update
   * DLA-373-1 : libxml2 security update
   * DLA-375-1 : ia32-libs security update
   * DLA-378-1 : linux-2.6 security update
   * DLA-379-1 : samba security update
   * DLA-381-1 : icu security update
   * DLA-382-1 : sudo security update
   * DLA-385-2 : isc-dhcp regression update
   * DLA-412-1 : linux-2.6 security update
   * DLA-415-1 : cpio security update
   * DLA-421-1 : openssl security update
   * DLA-423-1 : krb5 security update
   * DLA-427-1 : nss security update
   * DLA-432-1 : postgresql-8.4 update
   * DLA-436-1 : ia32-libs security update
   * DLA-439-1 : linux-2.6 security update
   * DLA-441-1 : pcre3 security update

 

This hotfix is installed on the SolarWinds LEM virtual appliance.

To install hotfix 2, verify that the virtual appliance is running Release 6.2.1
or 6.2.1 HF1. When completed, install Hotfix 2 on the following LEM components:

- LEM Manager
- LEM Database Server

If you are using a LEM configuration with a separate LEM Database Server, apply
this hotfix separately on both the Manager and Database appliances. The
installation process is the same for both appliance types.


VERIFYING THE LEM APPLIANCE RELEASE VERSION

   1.  Open the LEM console and authenticate to the LEM virtual appliance.

   2.  Click Manage > Appliances.

   3.  Under the Version column, check the current LEM version.

       If the version is Release 6.2.1 or 6.2.1 HF1, install the hotfix.

       If the version is not Release 6.2.1 or 6.2.1 HF1, do not install the hotfix.


INSTALLING HOTFIX 2 ON THE LEM APPLIANCE

   1.  Using the LEM Console or an SSH client (such as PuTTY), log in to the CMC.

       At the cmc> prompt, enter:

       manager

   2.  At the cmc::cmm# prompt, enter:
       hotfix

   3.  Follow the directions in the command prompt window to ensure that Hotfix 2
       is copied from the network share and applied to the LEM appliance.

   4.  Reboot the LEM appliance:

       a.  Exit the cmm# prompt or at the cmc# prompt, enter:

           appliance

       b.  At the prompt, enter:

           reboot

   5.  After the reboot, log in to the CMC and verify the hotfix was applied
       correctly.

       At the prompt, enter:

       manager

   6.  At the prompt, enter:

       viewsysinfo

       The system information appears on your screen.

   7.  At the top of your screen, the following message should appear if Hotfix 2
       was installed correctly:

       TriGeo manager version is: 6.2.1
       TriGeo manager build is: hotfix2

       Hotfix 2 is installed on LEM Manager.


UNINSTALLING HOTFIX 2

   To uninstall Hotfix 2, contact SolarWinds Support at
   https://support.solarwinds.com/Success_Center.

 

 

 

 

Last modified
02:33, 24 Aug 2016

Tags

Classifications

Public