Submit a ticketCall us

Don’t fall victim to a ransomware attack
Backups are helpful, but sometimes that’s not enough to protect your business against ransomware. At our live webcast we will discuss how to protect against ransomware attacks with SolarWinds® Patch Manager and how to leverage log data to detect ransomware. Register now for our live webcast.

Home > Success Center > Kiwi Syslog Server > NTFS compression on directories with log files

NTFS compression on directories with log files

Created by Albert Lopez, last modified by MindTouch on Jun 23, 2016

Views: 23 Votes: 0 Revisions: 7

Overview

This article provides brief information and steps to resolve the following Kiwi Syslog debug file: 

Debug Log - Log to file action - Error: Win32File Object [45620] Error opening 'D:\LOGS\Switches\2015-10-24.txt'. Error 32: The process cannot access the file because it is being used by another process.

Reference: https://support.microsoft.com/en-us/kb/251186

Environment

  • All Kiwi Syslog Server versions
  • All Windows O/S types

Cause 

The error is caused by a Windows compressed drive C:\ or D:\.  The log files are stored in folder \logs\switches.

Windows compresses the folders and locks out the service during that compression, which cause the error, as the incoming logs could no longer be written to the file path selected.

Resolution

  1. Stop the compression on the directory.
  2. Move the logs from this directory.
  3. Create a backup location for the logs, so nothing is missed when compression locks out KSS.

 

 

Last modified
19:50, 22 Jun 2016

Tags

Classifications

Public