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Home > Success Center > Kiwi Syslog Server > Kiwi Sys - Knowledgebase Articles > Kiwi Syslog Crashes with the error: out of stack space

Kiwi Syslog Crashes with the error: out of stack space

Updated: August 15, 2016

Overview

This article describes the issue when Kiwi Syslog Server constantly crashes and halts and you receive the following error: out of stack space

 

This issue may also be giving you less messages than the 2,000,000 maximum messages.

Environment

  • All versions of Kiwi Syslog Server 
  • All Supported OS

Cause 

Sending too many messages to the Kiwi Syslog Server all at once combined with having:

  • DNS lookup enabled
  • several configured action rules, such as Log to Database, Email and so on.

Resolution

1. Generate a Tech-SupportFile.zip file.
2. Go to File > Create Tech-SupportFile.zip

3. Open the file.
 

 

(note the above is for illustration purposes only)

According to the above example diagnostics

  • Receiving 1,796,400 messages per hour - Without DNS enabled Kiwi can handle up to 2,000,000
  • Resolving DNS - resource hungry - and a lot of errors caused due to insufficient resources,.


It is likely that you are pushing Kiwi Syslog too far and the best way to fix that is to disable DNS lookup.
 

Disable DNS Lookup

Example breakdown of syslog messages (this message breakdown may be different for your system):

Stop receiving messages with a level of "Notice," "Information," and Debug. Message with levels of "Warning" and above are usually enough, unless you have a legal requirement to store other message levels below "Warning."

 

The Kiwi Syslog application or service may stop if it is receiving more than 20 thousand messages per hour and IP resolution is enabled for messages.

 

To fix this restriction, complete the following steps: 

  1. Open the Kiwi Syslog Server interface.
  2. Click File > Setup.
  3. Click DNS Resolution.
  4. Uncheck the box: "Resolve IP addresses within the message text."
  5. Click OK.

 

Confirm if Kiwi Syslog Server continues to stop when receiving messages.  If it does, please perform the following:

  1. Open the Kiwi Syslog Server application.
  2. Move down to the Message Buffer Information section and ensure that Message Queue Overflow is at 0. 
  3. If it the message queue overflow is not at 0, increase the MessageBuffer size to a value that exceeds the sum of "Message Queue Max Size" and "Message Queue overflow". 

How to Increase MessageBuffer Size

  1. On the Kiwi Syslog Server, open the registry editor (regedit.exe).
  2. Open one of the following branchs, depending on your version:
    Version 8 or earlier: HKEY_LOCAL_MACHINE\SOFTWARE\Kiwi Enterprises\Syslogd\properties\ 
    Version 9 or later: HKEY_LOCAL_MACHINE\SOFTWARE\SolarWinds\Syslogd\properties\
  3. Add the following string value:
    name: MsgBufferSize
    value: ###  

    *** where ### is the sum of the Message Queue Max Size and Message Queue Overflow, plus some room for growth.

 

Restart the Kiwi Syslog Service/Manager.

 

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