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Home > Success Center > IP Address Manager (IPAM) > Unable to open IPAM views after migrating polling servers

Unable to open IPAM views after migrating polling servers

Updated August 10, 2016

Overview

This article addresses the issue where you are unable to open the following specific views in IPAM after a migration from one poller to another:

  • Manage IPs & Subnets
  • Manage DHCP and DNS Servers

The following error is displayed:

Infrastructure Component is Offline

The information Service and Orion Module Engine are required components for this website to function, and at least one of them is currently unavailable.

The OrionWeb.log file also contains the following error:

2016-08-08 10:39:48,238 [27] ERROR SolarWinds.IPAM.Web.Common.CommonPageServices - unable to communicate with SWIS or Business Layer
System.ServiceModel.EndpointNotFoundException: Could not connect to net.tcp://orionA:17777/orion/ipam/businesslayer. The connection attempt lasted for a time span of 00:00:21.0198470. TCP error code 10060: A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond X.X.X.X:17777.  ---> System.Net.Sockets.SocketException: A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond X.X.X.X:17777

 

Environment

IPAM versions 3 and 4

Cause 

This issue occurs when the previous poller engine still exists in the database, as well as the new engine, but the application defaults to the original poller. The website goes to the database to confirm which server IPAM is installed on, then uses that within the URL to populate the address. With the old poller still in place, the views cannot be displayed as that server is no longer available.

 

As the error example shows, you can see that the net.tcp connection is trying to connect to IPAM at this location: net.tcp://orionA:17777/orion/ipam/businesslayer. In this case, the application was migrated from the server orionA to orionB. The net.tcp connection to IPAM is still utilizing the older server information, resulting in a failed connection.

Resolution

You will need to make the following modifications to your Orion database: 

  1. Verify the names of the Orion pollers as listed in the AllEngines or Engines database tables (table varies depending on whether you are on IPAM 4.3 earlier or later).
  2. Query the IPAM_Engine table.
  3. Remove engines within the IPAM_Engine table that are no longer present under the AllEngines or Engines table.
  4. Query the WebSettings table.
  5. Verify if the JobSchedulerHost entry is for the new poller or the old poller. If it is for the old poller, replace it with the new poller name from the AllEngines or Engines table. This will enable IPAM to grab the correct engine names for net.tcp connections within the Orion website.
 

 

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