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Home > Success Center > IP Address Manager (IPAM) > IPAM - Knowledgebase Articles > Subnet Scans and other Polling are not occurring

Subnet Scans and other Polling are not occurring

Created by Jeremy Holmes, last modified by MindTouch on Jun 23, 2016

Views: 1,139 Votes: 0 Revisions: 3

Overview

Subnet Scans are not running and other polling appears to be broken as well. 

 

The IPAM.BusinessLayer.log has the error string below. 

 

**** 2016-02-09 09:55:41,750 [76] WARN  SolarWinds.IPAM.Jobs.JobScheduler (null) - ExecutionEngineExists: JobScheduler channel threw CommunicationException. Retries: 2
**** 2016-02-09 09:55:41,750 [76] WARN  SolarWinds.IPAM.Jobs.JobScheduler (null) - Job Scheduler Exception:
System.ServiceModel.EndpointNotFoundException: There was no endpoint listening at net.pipe://localhost/solarwinds/jobengine/router that could accept the message. This is often caused by an incorrect address or SOAP action. See InnerException, if present, for more details. ---> System.IO.PipeException: The pipe endpoint 'net.pipe://localhost/solarwinds/jobengine/router' could not be found on your local machine. 
   --- End of inner exception stack trace ---

 

The JobEngine v.2 logs are missing or blank.

Environment

IPAM 4.3

Cause 

The JobEnginev2 is corrupted/broken that causes jobs to not run properly. 

Resolution

  1. Log in to your server as the Local Administrator.
  2. Turn off UAC (User Account Control) if it is turned on. This requires a reboot.
  3. Stop all services using the Orion Service Manager. (Start-> All Programs->SolarWinds Orion-> Advanced Features-> Database Manager)
  4. Click Control Panel > Programs and Features, and uninstall the following:
    • SolarWinds Job Engine v1
    • SolarWinds Job Engine v2
    • SolarWinds Collector
    • SolarWinds Information Service
  5. Navigate to C:\ProgramData\Solarwinds\Installers.
  6. Run the following msi files:
    • CollectorInstall.msi
    • JobEngine.msi
    • JobEngine.v2.msi
    • InformationService.msi
  7. Start all services using the Orion Service Manager. Give the site a few minutes to refresh and then wait for 2-3 polling cycles to check.
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