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Home > Success Center > IP Address Manager (IPAM) > Command Failed: An unexpected error has occurred when processing DHCP scopes results for server

Command Failed: An unexpected error has occurred when processing DHCP scopes results for server

Overview

While scanning the DHCP servers running on Windows Server 2012, IPAM fails with the error:

Command Failed: An unexpected error has occurred when processing DHCP scopes results for server 'X'

 

Depending on what is found in the ipambusinesslayer logs will determine which portion is failing. There are several possible reasons, but the general 2 are outlined.

 

First has to do if the error pertains to a value missing out of the scopes being scanned. Generally it will look like this:

 

ERROR SolarWinds.IPAM.ScanningEngine.JobProcessor.JobProcessorBase`1 (null) - Error occurred when processing DHCP results - serverGroupId: X, serverNodeId: X
System.Data.SqlClient.SqlException (0x80131904): Cannot insert the value NULL into column 'X', table 'X'; column does not allow nulls. INSERT fails.

Second has to do if the error pertains to a SqlDateTime overflow:

SolarWinds.IPAM.ScanningEngine.JobProcessor.JobProcessorBase`1 (null) - Error occurred when processing DHCP results - serverGroupId: X, serverNodeId: X
System.Data.SqlTypes.SqlTypeException: SqlDateTime overflow. Must be between 1/1/1753 12:00:00 AM and 12/31/9999 11:59:59 PM.

Environment

All versions of IPAM

Windows DHCP 2012

Resolution

For First Cause:

To verify and remove the Type value Unknown from your scope:

  1. Go to IPAM Web Console > DHCP & DNS Management.
  2. Check if any IP address lease in your scopes has the Type value of Unknown or the scope itself has a missing Option.
  3. For Type values with Unknown, select the scope and then click Remove. The DHCP server is now able to scan without error.
  4. For Option values that are empty, select the scope and then click Remove. The DHCP server is now able to scan without error.

 

For Second Cause:

  1. Navigate to the DHCP server
  2. Check the leases for all in use IPs and reserved IPs
  3. For any that have a date before or after the needed range, have the customer modify it to be within the range
  4. Rescan the scope and it should add it back in.

Cause

There are 2 possible causes of this, depending on the errrors that are seen in the IPAM Businesslayer logs:

 

1st: The scope type has a value of Unknown on the DHCP server for the Type filed on an address lease. The DHCP scan cannot process the Unknown value and fails the DHCP scan. Other possibilities include missing scope Option in the scope details on the DHCP server

 

2nd: The scope has a lease time that is set before or after the ranges in the error within a reserved IP.

Last modified
14:24, 13 Nov 2015

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