Submit a ticketCall us

Solarwinds & Cisco Live! Barcelona
Join us from the 29th of January to the 2nd of February at Cisco Live 2018 in Barcelona, where we will continue to show how monitoring the network with SolarWinds will keep you ahead of the game. At our booth (WEP 1A), we will demonstrate how SolarWinds network solutions can help. As a bonus, we are also hosting a pre-event webinar - Blame the Network, Hybrid IT Edition with our SolarWinds Head Geek™, Patrick Hubbard on January 24th - GMT (UTC+0): 10:00 a.m. to 11:00 a.m. There's still time to RSVP.

Home > Success Center > IP Address Manager (IPAM) > Cisco DHCP device requirements for Orion IPAM

Cisco DHCP device requirements for Orion IPAM

Table of contents
No headers

When trying to add Cisco DHCP devices in IPAM, the devices being added must support the following:

1. Cisco Commands that need to be supported:
 - ‘show running-config’
 - ‘show ip dhcp pool’
 - ‘show ip dhcp binding’
2. The device needs to be a Layer 3 Switch or Router.
3. The IOS must be version 12.2(8)T or later.

Note: Enable level 15 is required to view the complete configuration. This is due to how IOS manages permission levels and configuration information.

For ASA devices, the following commands are needed:

-show dhcpd binding
-show running-config dhcpd
-show dhscpd statistics
-show interface l inc interface l ip address
-enable level set to enable 

asacred.png
 For more details see this Cisco article.

 

Note:

Cisco DHCP nodes should be assigned to the Main poller only, not on additional Poller due to the following reasons:

  • https://support.solarwinds.com/Succe...gines_and_IPAM
  • IPAM itself is a primary poller only based module, meaning that it is designed to only run and install on the Primary poller. Since IPAM is a module of the Orion suite though, it does require and come bundled with the Orion Core application that is the backbone of the Orion suite.

  • The actual IPAM Poller package itself does not have the IPAM installer but does contain the Orion Core installer that is bundled with the full IPAM installer package. This is required in the event that an IPAM upgrade moved up the version of Core on the Primary poller. This in turn causes the Core versions to then be mismatched on the additional poller. 

 

 

This KB applies to IPAM v1.7 and above.
Last modified

Tags

Classifications

Public